summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-sota/ostree/ostree_git.bb32
-rw-r--r--recipes-support/fuse/fuse_%.bbappend3
-rw-r--r--recipes-support/glib-networking/glib-networking_%.bbappend1
-rw-r--r--recipes-support/gpgme/gpgme_%.bbappend1
-rw-r--r--recipes-support/libgsystem/libgsystem_git.bb (renamed from recipes-sota/libgsystem/libgsystem_git.bb)9
-rw-r--r--recipes-support/libsoup/libsoup-2.4_%.bbappend3
-rw-r--r--recipes-support/util-linux/util-linux_%.bbappend10
7 files changed, 44 insertions, 15 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 659ee83..0e53d25 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -4,24 +4,35 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4 4
5inherit autotools-brokensep pkgconfig systemd 5inherit autotools-brokensep pkgconfig systemd
6 6
7INHERIT_remove_class-native = "systemd"
8
7SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
8SRCREV="v2016.9" 10SRCREV="v2016.9"
9 11
10S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
11 13
14BBCLASSEXTEND = "native"
15
12DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd" 16DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd"
17DEPENDS_remove_class-native = "systemd-native"
18
19RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz"
20RDEPENDS_${PN}_remove_class-native = "python-native"
13 21
14RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma" 22EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
23
24SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
25SYSTEMD_REQUIRED_class-native = ""
26
27SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
28SYSTEMD_SERVICE_${PN}_class-native = ""
15 29
16PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 30PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
31PACKAGECONFIG_class-native = ""
17PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,," 32PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
18 33
19EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
20
21FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" 34FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
22 35
23BBCLASSEXTEND = "native"
24
25export STAGING_INCDIR 36export STAGING_INCDIR
26export STAGING_LIBDIR 37export STAGING_LIBDIR
27 38
@@ -35,19 +46,18 @@ do_compile_prepend() {
35 export HOST_SYS="${HOST_SYS}" 46 export HOST_SYS="${HOST_SYS}"
36} 47}
37 48
49export SYSTEMD_REQUIRED
50
38do_install_append() { 51do_install_append() {
39 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 52 if [ -n ${SYSTEMD_REQUIRED} ]; then
40 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service 53 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
41 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service 54 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
42 fi 55 fi
43} 56}
44 57
45SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
46FILES_${PN} += " \ 58FILES_${PN} += " \
47 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \ 59 ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
48 ${datadir}/gir-1.0 \ 60 ${datadir}/gir-1.0 \
49 ${datadir}/gir-1.0/OSTree-1.0.gir \ 61 ${datadir}/gir-1.0/OSTree-1.0.gir \
50 ${libdir}/dracut/ \
51 ${libdir}/girepository-1.0 \
52 ${libdir}/girepository-1.0/OSTree-1.0.typelib \
53" 62"
63
diff --git a/recipes-support/fuse/fuse_%.bbappend b/recipes-support/fuse/fuse_%.bbappend
new file mode 100644
index 0000000..4f23349
--- /dev/null
+++ b/recipes-support/fuse/fuse_%.bbappend
@@ -0,0 +1,3 @@
1BBCLASSEXTEND = "native"
2
3PACKAGES_append_class-native = "fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native"
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend
new file mode 100644
index 0000000..d3267ac
--- /dev/null
+++ b/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -0,0 +1 @@
BBCLASSEXTEND = "native"
diff --git a/recipes-support/gpgme/gpgme_%.bbappend b/recipes-support/gpgme/gpgme_%.bbappend
new file mode 100644
index 0000000..d3267ac
--- /dev/null
+++ b/recipes-support/gpgme/gpgme_%.bbappend
@@ -0,0 +1 @@
BBCLASSEXTEND = "native"
diff --git a/recipes-sota/libgsystem/libgsystem_git.bb b/recipes-support/libgsystem/libgsystem_git.bb
index fe1e552..4b1eb49 100644
--- a/recipes-sota/libgsystem/libgsystem_git.bb
+++ b/recipes-support/libgsystem/libgsystem_git.bb
@@ -7,13 +7,14 @@ SRCREV="d606bec68ddfea78de4b03c3f3568afb71bdc1ce"
7 7
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10DEPENDS += "attr glib-2.0 pkgconfig libcap" 10inherit autotools-brokensep
11 11
12RDEPENDS_${PN} = "systemd liblzma" 12DEPENDS += "attr glib-2.0 pkgconfig libcap"
13RDEPENDS_${PN} = "xz systemd"
13 14
14inherit autotools-brokensep 15RDEPENDS_${PN}_remove_class-native = "systemd-native"
15 16
16BBCLASSEXTEND += "native" 17BBCLASSEXTEND = "native"
17 18
18export STAGING_INCDIR 19export STAGING_INCDIR
19export STAGING_LIBDIR 20export STAGING_LIBDIR
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend
new file mode 100644
index 0000000..ed24273
--- /dev/null
+++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -0,0 +1,3 @@
1BBCLASSEXTEND = "native"
2
3DEPENDS_append_class-native = " glib-networking-native"
diff --git a/recipes-support/util-linux/util-linux_%.bbappend b/recipes-support/util-linux/util-linux_%.bbappend
new file mode 100644
index 0000000..bd3f686
--- /dev/null
+++ b/recipes-support/util-linux/util-linux_%.bbappend
@@ -0,0 +1,10 @@
1PACKAGES_append_class-native = "util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native \
2 util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native \
3 util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native \
4 util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid \
5 util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native \
6 util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native \
7 util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock \
8 util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native \
9 ${@bb.utils.contains('PACKAGECONFIG', 'pylibmount', 'util-linux-pylibmount-native', '', d)}"
10