diff options
-rw-r--r-- | lib/oeqa/selftest/cases/updater.py | 2 | ||||
-rwxr-xr-x | recipes-sota/aktualizr/aktualizr_git.bb | 9 |
2 files changed, 9 insertions, 2 deletions
diff --git a/lib/oeqa/selftest/cases/updater.py b/lib/oeqa/selftest/cases/updater.py index 190d85d..08fb696 100644 --- a/lib/oeqa/selftest/cases/updater.py +++ b/lib/oeqa/selftest/cases/updater.py | |||
@@ -554,7 +554,7 @@ class SecondaryTests(OESelftestTestCase): | |||
554 | 554 | ||
555 | def test_secondary_listening(self): | 555 | def test_secondary_listening(self): |
556 | print('Checking aktualizr-secondary service is listening') | 556 | print('Checking aktualizr-secondary service is listening') |
557 | stdout, stderr, retcode = self.qemu_command('echo test | nc localhost 9030') | 557 | stdout, stderr, retcode = self.qemu_command('aktualizr-check-discovery') |
558 | self.assertEqual(retcode, 0, "Unable to connect to secondary") | 558 | self.assertEqual(retcode, 0, "Unable to connect to secondary") |
559 | 559 | ||
560 | 560 | ||
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index a2d03f2..a6e7dd2 100755 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -15,6 +15,9 @@ RDEPENDS_${PN}_append_class-target = "${@bb.utils.contains('SOTA_CLIENT_FEATURES | |||
15 | RDEPENDS_${PN}_append_class-target = " ${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'u-boot-fw-utils', '')}" | 15 | RDEPENDS_${PN}_append_class-target = " ${@oe.utils.ifelse(d.getVar('OSTREE_BOOTLOADER', True) == 'u-boot', 'u-boot-fw-utils', '')}" |
16 | RDEPENDS_${PN}_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'ubootenv', ' aktualizr-uboot-env-rollback', '', d)} " | 16 | RDEPENDS_${PN}_append_class-target = " ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'ubootenv', ' aktualizr-uboot-env-rollback', '', d)} " |
17 | 17 | ||
18 | RDEPENDS_${PN}_append_class-target = " ${PN}-tools " | ||
19 | RDEPENDS_${PN}-secondary_append_class-target = " ${PN}-tools " | ||
20 | |||
18 | PV = "1.0+git${SRCPV}" | 21 | PV = "1.0+git${SRCPV}" |
19 | PR = "7" | 22 | PR = "7" |
20 | 23 | ||
@@ -85,7 +88,7 @@ do_install_append_class-native () { | |||
85 | install -m 0644 ${B}/src/sota_tools/garage-sign/lib/* ${D}${libdir} | 88 | install -m 0644 ${B}/src/sota_tools/garage-sign/lib/* ${D}${libdir} |
86 | } | 89 | } |
87 | 90 | ||
88 | PACKAGES =+ " ${PN}-examples ${PN}-host-tools ${PN}-secondary " | 91 | PACKAGES =+ " ${PN}-examples ${PN}-host-tools ${PN}-tools ${PN}-secondary " |
89 | 92 | ||
90 | FILES_${PN} = " \ | 93 | FILES_${PN} = " \ |
91 | ${bindir}/aktualizr \ | 94 | ${bindir}/aktualizr \ |
@@ -116,6 +119,10 @@ FILES_${PN}-host-tools = " \ | |||
116 | ${libdir}/sota/sota_uboot_env.toml \ | 119 | ${libdir}/sota/sota_uboot_env.toml \ |
117 | " | 120 | " |
118 | 121 | ||
122 | FILES_${PN}-tools = " \ | ||
123 | ${bindir}/aktualizr-check-discovery \ | ||
124 | " | ||
125 | |||
119 | FILES_${PN}-secondary = " \ | 126 | FILES_${PN}-secondary = " \ |
120 | ${bindir}/aktualizr-secondary \ | 127 | ${bindir}/aktualizr-secondary \ |
121 | ${libdir}/sota/sota_secondary.toml \ | 128 | ${libdir}/sota/sota_secondary.toml \ |