diff options
-rw-r--r-- | classes/image_types_ostree.bbclass | 11 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 2 |
2 files changed, 10 insertions, 3 deletions
diff --git a/classes/image_types_ostree.bbclass b/classes/image_types_ostree.bbclass index 0e047b1..0f0fd28 100644 --- a/classes/image_types_ostree.bbclass +++ b/classes/image_types_ostree.bbclass | |||
@@ -186,13 +186,20 @@ IMAGE_CMD_ostreecommit () { | |||
186 | IMAGE_TYPEDEP_ostreepush = "ostreecommit" | 186 | IMAGE_TYPEDEP_ostreepush = "ostreecommit" |
187 | do_image_ostreepush[depends] += "aktualizr-native:do_populate_sysroot ca-certificates-native:do_populate_sysroot" | 187 | do_image_ostreepush[depends] += "aktualizr-native:do_populate_sysroot ca-certificates-native:do_populate_sysroot" |
188 | IMAGE_CMD_ostreepush () { | 188 | IMAGE_CMD_ostreepush () { |
189 | # Print warnings if credetials are not set or if the file has not been found. | 189 | # send a copy of the repo manifest to backend if available |
190 | local SEND_MANIFEST="" | ||
191 | # check if garage-push supports the --repo-manifest option before trying | ||
192 | if $(garage-push --help | grep -q '^\s*--repo-manifest') && [ -f ${IMAGE_ROOTFS}${sysconfdir}/manifest.xml ]; then | ||
193 | SEND_MANIFEST="--repo-manifest ${IMAGE_ROOTFS}${sysconfdir}/manifest.xml" | ||
194 | fi | ||
195 | |||
190 | if [ -n "${SOTA_PACKED_CREDENTIALS}" ]; then | 196 | if [ -n "${SOTA_PACKED_CREDENTIALS}" ]; then |
191 | if [ -e ${SOTA_PACKED_CREDENTIALS} ]; then | 197 | if [ -e ${SOTA_PACKED_CREDENTIALS} ]; then |
192 | garage-push -vv --repo=${OSTREE_REPO} \ | 198 | garage-push -vv --repo=${OSTREE_REPO} \ |
193 | --ref=${OSTREE_BRANCHNAME} \ | 199 | --ref=${OSTREE_BRANCHNAME} \ |
194 | --credentials=${SOTA_PACKED_CREDENTIALS} \ | 200 | --credentials=${SOTA_PACKED_CREDENTIALS} \ |
195 | --cacert=${STAGING_ETCDIR_NATIVE}/ssl/certs/ca-certificates.crt | 201 | --cacert=${STAGING_ETCDIR_NATIVE}/ssl/certs/ca-certificates.crt \ |
202 | $SEND_MANIFEST | ||
196 | else | 203 | else |
197 | bbwarn "SOTA_PACKED_CREDENTIALS file does not exist." | 204 | bbwarn "SOTA_PACKED_CREDENTIALS file does not exist." |
198 | fi | 205 | fi |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 22cba07..7e4115a 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -30,7 +30,7 @@ SRC_URI = " \ | |||
30 | SRC_URI[garagesign.md5sum] = "de0877ecb693fd48ec11052e51b0ff1a" | 30 | SRC_URI[garagesign.md5sum] = "de0877ecb693fd48ec11052e51b0ff1a" |
31 | SRC_URI[garagesign.sha256sum] = "cf25759574c9c1206835daeaf6fc345f6db7b5ccdb95fb828c86d7451f78f0aa" | 31 | SRC_URI[garagesign.sha256sum] = "cf25759574c9c1206835daeaf6fc345f6db7b5ccdb95fb828c86d7451f78f0aa" |
32 | 32 | ||
33 | SRCREV = "fa59e33208d3b1dc690a30ce8339b3b4162f8022" | 33 | SRCREV = "9677f025abbb958ad36d4b58cae1dd4fe5750cf0" |
34 | BRANCH ?= "master" | 34 | BRANCH ?= "master" |
35 | 35 | ||
36 | S = "${WORKDIR}/git" | 36 | S = "${WORKDIR}/git" |