diff options
-rw-r--r-- | classes/sota.bbclass | 3 | ||||
-rw-r--r-- | lib/oeqa/selftest/cases/updater_qemux86_64.py | 3 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 12 |
3 files changed, 9 insertions, 9 deletions
diff --git a/classes/sota.bbclass b/classes/sota.bbclass index dc18cbc..fde00cd 100644 --- a/classes/sota.bbclass +++ b/classes/sota.bbclass | |||
@@ -1,12 +1,11 @@ | |||
1 | DISTROOVERRIDES .= "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ':sota', '', d)}" | 1 | DISTROOVERRIDES .= "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ':sota', '', d)}" |
2 | 2 | ||
3 | SOTA_CLIENT ??= "aktualizr" | ||
4 | SOTA_CLIENT_PROV ??= "aktualizr-shared-prov" | 3 | SOTA_CLIENT_PROV ??= "aktualizr-shared-prov" |
5 | SOTA_DEPLOY_CREDENTIALS ?= "1" | 4 | SOTA_DEPLOY_CREDENTIALS ?= "1" |
6 | SOTA_HARDWARE_ID ??= "${MACHINE}" | 5 | SOTA_HARDWARE_ID ??= "${MACHINE}" |
7 | 6 | ||
8 | IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest" | 7 | IMAGE_CLASSES += " image_types_ostree image_types_ota image_repo_manifest" |
9 | IMAGE_INSTALL_append_sota = " ${SOTA_CLIENT} ${SOTA_CLIENT_PROV} \ | 8 | IMAGE_INSTALL_append_sota = " aktualizr aktualizr-info ${SOTA_CLIENT_PROV} \ |
10 | ostree os-release ostree-kernel \ | 9 | ostree os-release ostree-kernel \ |
11 | ${@'ostree-initramfs' if d.getVar('KERNEL_IMAGETYPE') != 'fitImage' else ''} \ | 10 | ${@'ostree-initramfs' if d.getVar('KERNEL_IMAGETYPE') != 'fitImage' else ''} \ |
12 | ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}" | 11 | ${@'ostree-devicetrees' if oe.types.boolean('${OSTREE_DEPLOY_DEVICETREE}') else ''}" |
diff --git a/lib/oeqa/selftest/cases/updater_qemux86_64.py b/lib/oeqa/selftest/cases/updater_qemux86_64.py index dfcb8e0..c7d0448 100644 --- a/lib/oeqa/selftest/cases/updater_qemux86_64.py +++ b/lib/oeqa/selftest/cases/updater_qemux86_64.py | |||
@@ -133,8 +133,7 @@ class SharedCredProvTestsNonOSTree(SharedCredProvTests): | |||
133 | self.append_config('PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf"') | 133 | self.append_config('PREFERRED_RPROVIDER_network-configuration ??= "networkd-dhcp-conf"') |
134 | self.append_config('PACKAGECONFIG_pn-aktualizr = ""') | 134 | self.append_config('PACKAGECONFIG_pn-aktualizr = ""') |
135 | self.append_config('SOTA_DEPLOY_CREDENTIALS = "1"') | 135 | self.append_config('SOTA_DEPLOY_CREDENTIALS = "1"') |
136 | self.append_config('IMAGE_INSTALL_append += "aktualizr"') | 136 | self.append_config('IMAGE_INSTALL_append += "aktualizr aktualizr-info aktualizr-shared-prov"') |
137 | self.append_config('IMAGE_INSTALL_append += " aktualizr-shared-prov"') | ||
138 | self.qemu, self.s = qemu_launch(machine='qemux86-64', uboot_enable='no') | 137 | self.qemu, self.s = qemu_launch(machine='qemux86-64', uboot_enable='no') |
139 | 138 | ||
140 | 139 | ||
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 4f32887..d77655d 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -132,23 +132,25 @@ PACKAGESPLITFUNCS_prepend = "split_hosttools_packages " | |||
132 | python split_hosttools_packages () { | 132 | python split_hosttools_packages () { |
133 | bindir = d.getVar('bindir') | 133 | bindir = d.getVar('bindir') |
134 | 134 | ||
135 | # Split all binaries to their own packages except aktualizr-info, | 135 | # Split all binaries to their own packages. |
136 | # aktualizr-info should stay in main package aktualizr. | 136 | do_split_packages(d, bindir, '^(.*)$', '%s', 'Aktualizr tool - %s', extra_depends='aktualizr-configs', prepend=False) |
137 | do_split_packages(d, bindir, r'^((?!(aktualizr-info)).*)$', '%s', 'Aktualizr tool - %s', extra_depends='aktualizr-configs', prepend=False) | ||
138 | } | 137 | } |
139 | 138 | ||
140 | PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" | 139 | PACKAGES_DYNAMIC = "^aktualizr-.* ^garage-.*" |
141 | 140 | ||
142 | PACKAGES =+ "${PN}-host-tools ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" | 141 | PACKAGES =+ "${PN}-host-tools ${PN}-info ${PN}-lib ${PN}-resource-control ${PN}-configs ${PN}-secondary ${PN}-secondary-lib ${PN}-sotatools-lib" |
143 | 142 | ||
144 | ALLOW_EMPTY_${PN}-host-tools = "1" | 143 | ALLOW_EMPTY_${PN}-host-tools = "1" |
145 | 144 | ||
146 | FILES_${PN} = " \ | 145 | FILES_${PN} = " \ |
147 | ${bindir}/aktualizr \ | 146 | ${bindir}/aktualizr \ |
148 | ${bindir}/aktualizr-info \ | ||
149 | ${systemd_unitdir}/system/aktualizr.service \ | 147 | ${systemd_unitdir}/system/aktualizr.service \ |
150 | " | 148 | " |
151 | 149 | ||
150 | FILES_${PN}-info = " \ | ||
151 | ${bindir}/aktualizr-info \ | ||
152 | " | ||
153 | |||
152 | FILES_${PN}-lib = " \ | 154 | FILES_${PN}-lib = " \ |
153 | ${libdir}/libaktualizr.so \ | 155 | ${libdir}/libaktualizr.so \ |
154 | " | 156 | " |