diff options
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 5 | ||||
-rw-r--r-- | recipes-support/boost/boost_1.72.0.bbappend | 4 | ||||
-rw-r--r-- | recipes-support/boost/files/0001-add-typedef-executor_type.patch | 56 |
3 files changed, 62 insertions, 3 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 804f2c2..30256b1 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -12,6 +12,8 @@ RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-cert-provider ${@bb.utils.conta | |||
12 | 12 | ||
13 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" | 13 | RDEPENDS_${PN}-ptest += "bash cmake curl net-tools python3-core python3-misc python3-modules openssl-bin sqlite3 valgrind" |
14 | 14 | ||
15 | PRIVATE_LIBS_${PN}-ptest = "libaktualizr.so libaktualizr_secondary.so" | ||
16 | |||
15 | PV = "1.0+git${SRCPV}" | 17 | PV = "1.0+git${SRCPV}" |
16 | PR = "7" | 18 | PR = "7" |
17 | 19 | ||
@@ -86,9 +88,6 @@ do_install_ptest() { | |||
86 | cp -r ${B}/ ${D}/${PTEST_PATH}/build | 88 | cp -r ${B}/ ${D}/${PTEST_PATH}/build |
87 | cp -r ${S}/ ${D}/${PTEST_PATH}/src | 89 | cp -r ${S}/ ${D}/${PTEST_PATH}/src |
88 | 90 | ||
89 | # remove huge external unused repository | ||
90 | rm -rf ${D}/${PTEST_PATH}/src/partial/extern/RIOT | ||
91 | |||
92 | # remove huge build artifacts | 91 | # remove huge build artifacts |
93 | find ${D}/${PTEST_PATH}/build/src -name "*.a" -delete | 92 | find ${D}/${PTEST_PATH}/build/src -name "*.a" -delete |
94 | 93 | ||
diff --git a/recipes-support/boost/boost_1.72.0.bbappend b/recipes-support/boost/boost_1.72.0.bbappend new file mode 100644 index 0000000..73ee73d --- /dev/null +++ b/recipes-support/boost/boost_1.72.0.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | ||
2 | |||
3 | SRC_URI += "file://0001-add-typedef-executor_type.patch \ | ||
4 | " | ||
diff --git a/recipes-support/boost/files/0001-add-typedef-executor_type.patch b/recipes-support/boost/files/0001-add-typedef-executor_type.patch new file mode 100644 index 0000000..1b326a4 --- /dev/null +++ b/recipes-support/boost/files/0001-add-typedef-executor_type.patch | |||
@@ -0,0 +1,56 @@ | |||
1 | From 99ad3ebac0b7466d57c98fb9583fbe8789729691 Mon Sep 17 00:00:00 2001 | ||
2 | From: Patrick Vacek <patrickvacek@gmail.com> | ||
3 | Date: Wed, 4 Mar 2020 12:41:02 +0000 | ||
4 | Subject: [PATCH] add typedef executor_type | ||
5 | |||
6 | Backported from here: | ||
7 | https://github.com/boostorg/process/commit/6a4d2ff72114ef47c7afaf92e1042aca3dfa41b0 | ||
8 | |||
9 | Suggested-by: Kostiantyn Bushko <kbushko@intellias.com> | ||
10 | Signed-off-by: Patrick Vacek <patrickvacek@gmail.com> | ||
11 | --- | ||
12 | boost/process/async_pipe.hpp | 2 ++ | ||
13 | boost/process/detail/posix/async_pipe.hpp | 1 + | ||
14 | boost/process/detail/windows/async_pipe.hpp | 1 + | ||
15 | 3 files changed, 4 insertions(+) | ||
16 | |||
17 | diff --git a/boost/process/async_pipe.hpp b/boost/process/async_pipe.hpp | ||
18 | index 101fe1d..a562432 100644 | ||
19 | --- a/boost/process/async_pipe.hpp | ||
20 | +++ b/boost/process/async_pipe.hpp | ||
21 | @@ -47,6 +47,8 @@ public: | ||
22 | */ | ||
23 | typedef platform_specific handle_type; | ||
24 | |||
25 | + typedef typename handle_type::executor_type executor_type; | ||
26 | + | ||
27 | /** Construct a new async_pipe, does automatically open the pipe. | ||
28 | * Initializes source and sink with the same io_context. | ||
29 | * @note Windows creates a named pipe here, where the name is automatically generated. | ||
30 | diff --git a/boost/process/detail/posix/async_pipe.hpp b/boost/process/detail/posix/async_pipe.hpp | ||
31 | index 725a078..a82c057 100644 | ||
32 | --- a/boost/process/detail/posix/async_pipe.hpp | ||
33 | +++ b/boost/process/detail/posix/async_pipe.hpp | ||
34 | @@ -23,6 +23,7 @@ class async_pipe | ||
35 | public: | ||
36 | typedef int native_handle_type; | ||
37 | typedef ::boost::asio::posix::stream_descriptor handle_type; | ||
38 | + typedef typename handle_type::executor_type executor_type; | ||
39 | |||
40 | inline async_pipe(boost::asio::io_context & ios) : async_pipe(ios, ios) {} | ||
41 | |||
42 | diff --git a/boost/process/detail/windows/async_pipe.hpp b/boost/process/detail/windows/async_pipe.hpp | ||
43 | index 06d5f2d..0b447f9 100644 | ||
44 | --- a/boost/process/detail/windows/async_pipe.hpp | ||
45 | +++ b/boost/process/detail/windows/async_pipe.hpp | ||
46 | @@ -48,6 +48,7 @@ class async_pipe | ||
47 | public: | ||
48 | typedef ::boost::winapi::HANDLE_ native_handle_type; | ||
49 | typedef ::boost::asio::windows::stream_handle handle_type; | ||
50 | + typedef typename handle_type::executor_type executor_type; | ||
51 | |||
52 | async_pipe(boost::asio::io_context & ios) : async_pipe(ios, ios, make_pipe_name(), true) {} | ||
53 | async_pipe(boost::asio::io_context & ios_source, boost::asio::io_context & ios_sink) | ||
54 | -- | ||
55 | 2.11.0 | ||
56 | |||