diff options
-rw-r--r-- | recipes-sota/config/aktualizr-disable-send-ip.bb | 3 | ||||
-rw-r--r-- | recipes-sota/config/aktualizr-example-interface.bb | 3 | ||||
-rw-r--r-- | recipes-sota/config/aktualizr-log-debug.bb | 3 | ||||
-rw-r--r-- | recipes-sota/config/files/30-disable-send-ip.toml | 2 | ||||
-rw-r--r-- | recipes-sota/config/files/30-example-interface.toml | 2 | ||||
-rw-r--r-- | recipes-sota/config/files/90-log-debug.toml | 2 |
6 files changed, 12 insertions, 3 deletions
diff --git a/recipes-sota/config/aktualizr-disable-send-ip.bb b/recipes-sota/config/aktualizr-disable-send-ip.bb index ce492e9..cab7696 100644 --- a/recipes-sota/config/aktualizr-disable-send-ip.bb +++ b/recipes-sota/config/aktualizr-disable-send-ip.bb | |||
@@ -7,11 +7,12 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241 | |||
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | file://LICENSE \ | 9 | file://LICENSE \ |
10 | file://30-disable-send-ip.toml \ | ||
10 | " | 11 | " |
11 | 12 | ||
12 | do_install_append () { | 13 | do_install_append () { |
13 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 14 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
14 | echo "[telemetry]\nreport_network = false\n" > ${D}${libdir}/sota/conf.d/30-disable-send-ip.toml | 15 | install -m 0644 ${WORKDIR}/30-disable-send-ip.toml ${D}${libdir}/sota/conf.d/30-disable-send-ip.toml |
15 | } | 16 | } |
16 | 17 | ||
17 | FILES_${PN} = " \ | 18 | FILES_${PN} = " \ |
diff --git a/recipes-sota/config/aktualizr-example-interface.bb b/recipes-sota/config/aktualizr-example-interface.bb index 52ebe1c..37a9184 100644 --- a/recipes-sota/config/aktualizr-example-interface.bb +++ b/recipes-sota/config/aktualizr-example-interface.bb | |||
@@ -7,11 +7,12 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241 | |||
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | file://LICENSE \ | 9 | file://LICENSE \ |
10 | file://30-example-interface.toml \ | ||
10 | " | 11 | " |
11 | 12 | ||
12 | do_install_append () { | 13 | do_install_append () { |
13 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 14 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
14 | echo "[uptane]\nlegacy_interface = \"/usr/bin/example-interface\"\n" > ${D}${libdir}/sota/conf.d/30-example-interface.toml | 15 | install -m 0644 ${WORKDIR}/30-example-interface.toml ${D}${libdir}/sota/conf.d/30-example-interface.toml |
15 | } | 16 | } |
16 | 17 | ||
17 | FILES_${PN} = " \ | 18 | FILES_${PN} = " \ |
diff --git a/recipes-sota/config/aktualizr-log-debug.bb b/recipes-sota/config/aktualizr-log-debug.bb index e32a414..5cfd198 100644 --- a/recipes-sota/config/aktualizr-log-debug.bb +++ b/recipes-sota/config/aktualizr-log-debug.bb | |||
@@ -7,11 +7,12 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=9741c346eef56131163e13b9db1241 | |||
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | file://LICENSE \ | 9 | file://LICENSE \ |
10 | file://90-log-debug.toml \ | ||
10 | " | 11 | " |
11 | 12 | ||
12 | do_install_append () { | 13 | do_install_append () { |
13 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 14 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
14 | echo "[logger]\nloglevel = 0\n" > ${D}${libdir}/sota/conf.d/90-log-debug.toml | 15 | install -m 0644 ${WORKDIR}/90-log-debug.toml ${D}${libdir}/sota/conf.d/90-log-debug.toml |
15 | } | 16 | } |
16 | 17 | ||
17 | FILES_${PN} = " \ | 18 | FILES_${PN} = " \ |
diff --git a/recipes-sota/config/files/30-disable-send-ip.toml b/recipes-sota/config/files/30-disable-send-ip.toml new file mode 100644 index 0000000..5cd5108 --- /dev/null +++ b/recipes-sota/config/files/30-disable-send-ip.toml | |||
@@ -0,0 +1,2 @@ | |||
1 | [telemetry] | ||
2 | report_network = false | ||
diff --git a/recipes-sota/config/files/30-example-interface.toml b/recipes-sota/config/files/30-example-interface.toml new file mode 100644 index 0000000..fc4e9ec --- /dev/null +++ b/recipes-sota/config/files/30-example-interface.toml | |||
@@ -0,0 +1,2 @@ | |||
1 | [uptane] | ||
2 | legacy_interface = "/usr/bin/example-interface" | ||
diff --git a/recipes-sota/config/files/90-log-debug.toml b/recipes-sota/config/files/90-log-debug.toml new file mode 100644 index 0000000..100a146 --- /dev/null +++ b/recipes-sota/config/files/90-log-debug.toml | |||
@@ -0,0 +1,2 @@ | |||
1 | [logger] | ||
2 | loglevel = 0 | ||