diff options
-rw-r--r-- | recipes-devtools/pseudo/files/fallback-group | 2 | ||||
-rw-r--r-- | recipes-devtools/pseudo/files/fallback-passwd | 1 | ||||
-rw-r--r-- | recipes-devtools/pseudo/pseudo_1.8.1.bb | 20 | ||||
-rw-r--r-- | recipes-sota/ostree-initrd/files/init.sh | 2 | ||||
-rw-r--r-- | recipes-sota/ostree/ostree_git.bb | 9 |
5 files changed, 29 insertions, 5 deletions
diff --git a/recipes-devtools/pseudo/files/fallback-group b/recipes-devtools/pseudo/files/fallback-group new file mode 100644 index 0000000..81bf732 --- /dev/null +++ b/recipes-devtools/pseudo/files/fallback-group | |||
@@ -0,0 +1,2 @@ | |||
1 | root:*:0: | ||
2 | mail:*:8: | ||
diff --git a/recipes-devtools/pseudo/files/fallback-passwd b/recipes-devtools/pseudo/files/fallback-passwd new file mode 100644 index 0000000..c1458dc --- /dev/null +++ b/recipes-devtools/pseudo/files/fallback-passwd | |||
@@ -0,0 +1 @@ | |||
root::0:0:root:/home/root:/bin/sh | |||
diff --git a/recipes-devtools/pseudo/pseudo_1.8.1.bb b/recipes-devtools/pseudo/pseudo_1.8.1.bb new file mode 100644 index 0000000..211439e --- /dev/null +++ b/recipes-devtools/pseudo/pseudo_1.8.1.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | require recipes-devtools/pseudo/pseudo.inc | ||
2 | |||
3 | SRC_URI = " \ | ||
4 | http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \ | ||
5 | file://fallback-passwd \ | ||
6 | file://fallback-group \ | ||
7 | file://0001-Add-check-for-existence-of-old-file-to-renameat.patch \ | ||
8 | " | ||
9 | |||
10 | SRC_URI[md5sum] = "ee38e4fb62ff88ad067b1a5a3825bac7" | ||
11 | SRC_URI[sha256sum] = "dac4ad2d21228053151121320f629d41dd5c0c87695ac4e7aea286c414192ab5" | ||
12 | |||
13 | PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback" | ||
14 | |||
15 | do_install_append_class-native () { | ||
16 | install -d ${D}${sysconfdir} | ||
17 | # The fallback files should never be modified | ||
18 | install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd | ||
19 | install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group | ||
20 | } | ||
diff --git a/recipes-sota/ostree-initrd/files/init.sh b/recipes-sota/ostree-initrd/files/init.sh index 5aa99d6..806a7b1 100644 --- a/recipes-sota/ostree-initrd/files/init.sh +++ b/recipes-sota/ostree-initrd/files/init.sh | |||
@@ -35,7 +35,7 @@ get_ostree_sysroot() { | |||
35 | done | 35 | done |
36 | } | 36 | } |
37 | 37 | ||
38 | export PATH=/sbin:/usr/sbin:/bin:/usr/bin | 38 | export PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/lib/ostree |
39 | 39 | ||
40 | log_info "starting initrd script" | 40 | log_info "starting initrd script" |
41 | 41 | ||
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb index b5675ab..c2aeb2f 100644 --- a/recipes-sota/ostree/ostree_git.bb +++ b/recipes-sota/ostree/ostree_git.bb | |||
@@ -8,7 +8,7 @@ INHERIT_remove_class-native = "systemd" | |||
8 | 8 | ||
9 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" | 9 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" |
10 | 10 | ||
11 | SRCREV="v2016.5" | 11 | SRCREV="v2016.11" |
12 | 12 | ||
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
@@ -20,8 +20,9 @@ DEPENDS_remove_class-native = "systemd-native" | |||
20 | RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz" | 20 | RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz" |
21 | RDEPENDS_${PN}_remove_class-native = "python-native" | 21 | RDEPENDS_${PN}_remove_class-native = "python-native" |
22 | 22 | ||
23 | EXTRA_OECONF = "CFLAGS='-DDISABLE_OTMPFILE' --with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man" | 23 | EXTRA_OECONF = "CFLAGS='-g' --with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man" |
24 | EXTRA_OEMAKE = "CFLAGS='-DDISABLE_OTMPFILE'" | 24 | EXTRA_OEMAKE = "CFLAGS='-g'" |
25 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" | ||
25 | 26 | ||
26 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" | 27 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" |
27 | SYSTEMD_REQUIRED_class-native = "" | 28 | SYSTEMD_REQUIRED_class-native = "" |
@@ -68,7 +69,7 @@ FILES_${PN} += " \ | |||
68 | 69 | ||
69 | PACKAGES =+ "${PN}-switchroot" | 70 | PACKAGES =+ "${PN}-switchroot" |
70 | 71 | ||
71 | FILES_${PN}-switchroot = "${sbindir}/ostree-prepare-root" | 72 | FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" |
72 | RDEPENDS_${PN}-switchroot = "" | 73 | RDEPENDS_${PN}-switchroot = "" |
73 | DEPENDS_remove_class-native = "systemd-native" | 74 | DEPENDS_remove_class-native = "systemd-native" |
74 | 75 | ||