diff options
-rw-r--r-- | lib/oeqa/selftest/cases/updater.py | 4 | ||||
-rwxr-xr-x | recipes-sota/aktualizr/aktualizr_git.bb | 2 |
2 files changed, 3 insertions, 3 deletions
diff --git a/lib/oeqa/selftest/cases/updater.py b/lib/oeqa/selftest/cases/updater.py index 92bf6fc..08521d5 100644 --- a/lib/oeqa/selftest/cases/updater.py +++ b/lib/oeqa/selftest/cases/updater.py | |||
@@ -214,7 +214,7 @@ class ManualControlTests(OESelftestTestCase): | |||
214 | def qemu_command(self, command): | 214 | def qemu_command(self, command): |
215 | return qemu_send_command(self.qemu.ssh_port, command) | 215 | return qemu_send_command(self.qemu.ssh_port, command) |
216 | 216 | ||
217 | def test_manual_running_mode_once(self): | 217 | def test_manual_run_mode_once(self): |
218 | """ | 218 | """ |
219 | Disable the systemd service then run aktualizr manually | 219 | Disable the systemd service then run aktualizr manually |
220 | """ | 220 | """ |
@@ -223,7 +223,7 @@ class ManualControlTests(OESelftestTestCase): | |||
223 | self.assertIn(b'Can\'t open database', stdout, | 223 | self.assertIn(b'Can\'t open database', stdout, |
224 | 'Aktualizr should not have run yet' + stderr.decode() + stdout.decode()) | 224 | 'Aktualizr should not have run yet' + stderr.decode() + stdout.decode()) |
225 | 225 | ||
226 | stdout, stderr, retcode = self.qemu_command('aktualizr --running-mode=once') | 226 | stdout, stderr, retcode = self.qemu_command('aktualizr once') |
227 | 227 | ||
228 | stdout, stderr, retcode = self.qemu_command('aktualizr-info') | 228 | stdout, stderr, retcode = self.qemu_command('aktualizr-info') |
229 | self.assertIn(b'Fetched metadata: yes', stdout, | 229 | self.assertIn(b'Fetched metadata: yes', stdout, |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index d49f28c..eb65ae0 100755 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -27,7 +27,7 @@ SRC_URI = " \ | |||
27 | file://aktualizr-serialcan.service \ | 27 | file://aktualizr-serialcan.service \ |
28 | " | 28 | " |
29 | 29 | ||
30 | SRCREV = "d00d1a04cc2366d1a5f143b84b9f507f8bd32c44" | 30 | SRCREV = "1cad6d10286ade64b24021ca0e23de0d3b64f520" |
31 | BRANCH ?= "master" | 31 | BRANCH ?= "master" |
32 | 32 | ||
33 | S = "${WORKDIR}/git" | 33 | S = "${WORKDIR}/git" |