summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/sota.bbclass38
-rw-r--r--classes/sota_minnowboard.bbclass6
-rw-r--r--classes/sota_minnowboard_uboot.inc8
-rw-r--r--classes/sota_none.bbclass3
-rw-r--r--conf/distro/poky-sota-systemd.conf6
-rw-r--r--conf/distro/poky-sota.conf3
-rw-r--r--conf/include/bblayers/sota_porter.inc2
-rw-r--r--recipes-bsp/grub/grub-efi_%.bbappend2
-rw-r--r--recipes-support/fuse/fuse_%.bbappend4
-rw-r--r--recipes-support/glib-networking/glib-networking_%.bbappend2
-rw-r--r--recipes-support/gpgme/gpgme_%.bbappend2
-rw-r--r--recipes-support/libsoup/libsoup-2.4_%.bbappend4
-rw-r--r--recipes-support/libssh2/libssh2_%.bbappend2
-rw-r--r--recipes-support/util-linux/util-linux_%.bbappend11
14 files changed, 47 insertions, 46 deletions
diff --git a/classes/sota.bbclass b/classes/sota.bbclass
index 0697932..ab9611a 100644
--- a/classes/sota.bbclass
+++ b/classes/sota.bbclass
@@ -1,19 +1,19 @@
1DISTRO_FEATURES_append = " sota" 1python __anonymous() {
2OVERRIDES .= ":sota" 2 if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d):
3 d.appendVar("OVERRIDES", ":sota")
4 #d.appendVar("IMAGE_INSTALL", " ostree os-release")
3 5
4IMAGE_INSTALL_append = " ostree os-release" 6 d.appendVarFlag("do_image_wic", "depends", " %s:do_image_otaimg" % d.getVar("IMAGE_BASENAME", True))
7 #d.appendVar("EXTRA_IMAGEDEPENDS", " parted-native mtools-native dosfstools-native")
8}
5 9
6# live image for OSTree-enabled systems 10IMAGE_INSTALL_append_sota = " ostree os-release"
7IMAGE_CLASSES += "image_types_ostree image_types_ota" 11IMAGE_CLASSES += " image_types_ostree image_types_ota"
8IMAGE_FSTYPES += "ostreepush otaimg" 12IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ostreepush otaimg wic', ' ', d)}"
9 13
10# if don't build wic image unless IMAGE_BOOT_FILES is set. Prevents build from failing 14WKS_FILE_sota ?= "sdimage-sota.wks"
11# on machines that don't support updater yet
12IMAGE_FSTYPES += "${@' wic' if (d.getVar("IMAGE_BOOT_FILES", True)) else ''}"
13WKS_FILE ?= "sdimage-sota.wks"
14do_image_wic[depends] += "${IMAGE_BASENAME}:do_image_otaimg"
15 15
16EXTRA_IMAGEDEPENDS += " parted-native mtools-native dosfstools-native" 16EXTRA_IMAGEDEPENDS_append_sota = " parted-native mtools-native dosfstools-native"
17 17
18# Please redefine OSTREE_REPO in order to have a persistent OSTree repo 18# Please redefine OSTREE_REPO in order to have a persistent OSTree repo
19OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo" 19OSTREE_REPO ?= "${DEPLOY_DIR_IMAGE}/ostree_repo"
@@ -21,13 +21,11 @@ OSTREE_BRANCHNAME ?= "ota-${MACHINE}"
21OSTREE_OSNAME ?= "poky" 21OSTREE_OSNAME ?= "poky"
22OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image" 22OSTREE_INITRAMFS_IMAGE ?= "initramfs-ostree-image"
23 23
24# Prelinking increases the size of downloads and causes build errors 24SOTA_MACHINE ??="none"
25USER_CLASSES_remove = "image-prelink" 25SOTA_MACHINE_raspberrypi2 ?= "raspberrypi"
26SOTA_MACHINE_rarpberrypi3 ?= "raspberrypi"
27SOTA_MACHINE_porter ?= "porter"
28SOTA_MACHINE_intel-corei7-64 ?= "minnowboard"
29SOTA_MACHINE_qemux86-64 ?= "qemux86-64"
26 30
27SOTA_MACHINE ?= "none"
28SOTA_MACHINE_raspberrypi = "raspberrypi"
29SOTA_MACHINE_raspberrypi3 = "raspberrypi"
30SOTA_MACHINE_porter = "porter"
31SOTA_MACHINE_intel-corei7-64 = "minnowboard"
32SOTA_MACHINE_qemux86-64 = "qemux86-64"
33inherit sota_${SOTA_MACHINE} 31inherit sota_${SOTA_MACHINE}
diff --git a/classes/sota_minnowboard.bbclass b/classes/sota_minnowboard.bbclass
index 970bd6a..8417348 100644
--- a/classes/sota_minnowboard.bbclass
+++ b/classes/sota_minnowboard.bbclass
@@ -1,7 +1,7 @@
1OSTREE_BOOTLOADER ?= "grub" 1OSTREE_BOOTLOADER ?= "grub"
2EFI_PROVIDER = "grub-efi" 2EFI_PROVIDER_sota = "grub-efi"
3 3
4WKS_FILE = "efiimage-sota.wks" 4WKS_FILE_sota = "efiimage-sota.wks"
5IMAGE_BOOT_FILES = "" 5IMAGE_BOOT_FILES_sota = ""
6 6
7OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0" 7OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 console=ttyS0,115200 console=tty0"
diff --git a/classes/sota_minnowboard_uboot.inc b/classes/sota_minnowboard_uboot.inc
index 5097e9d..85d6a60 100644
--- a/classes/sota_minnowboard_uboot.inc
+++ b/classes/sota_minnowboard_uboot.inc
@@ -1,8 +1,8 @@
1PREFERRED_PROVIDER_virtual/bootloader = "u-boot-ota" 1PREFERRED_PROVIDER_virtual/bootloader_sota ?= "u-boot-ota"
2UBOOT_MACHINE = "minnowmax_defconfig" 2UBOOT_MACHINE_sota ?= "minnowmax_defconfig"
3 3
4EXTRA_IMAGEDEPENDS_append = " minnowboard-bootfiles" 4EXTRA_IMAGEDEPENDS_append_sota = " minnowboard-bootfiles"
5IMAGE_BOOT_FILES = "minnowboard-bootfiles/*" 5IMAGE_BOOT_FILES_sota ?= "minnowboard-bootfiles/*"
6 6
7OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda console=ttyS0,115200 console=tty0" 7OSTREE_KERNEL_ARGS ?= "ramdisk_size=16384 rw rootfstype=ext4 rootwait rootdelay=2 ostree_root=/dev/hda console=ttyS0,115200 console=tty0"
8 8
diff --git a/classes/sota_none.bbclass b/classes/sota_none.bbclass
index dc72a07..86eaf0b 100644
--- a/classes/sota_none.bbclass
+++ b/classes/sota_none.bbclass
@@ -1 +1,4 @@
1# null machine it's here to make bitbake happy when SOTA_MACHINE is undefined 1# null machine it's here to make bitbake happy when SOTA_MACHINE is undefined
2python __anonymous() {
3 bb.warn("SOTA functionality is not yet supported for your machine")
4}
diff --git a/conf/distro/poky-sota-systemd.conf b/conf/distro/poky-sota-systemd.conf
index e6f43f7..78ca1e5 100644
--- a/conf/distro/poky-sota-systemd.conf
+++ b/conf/distro/poky-sota-systemd.conf
@@ -1,5 +1,7 @@
1require conf/distro/poky.conf 1require conf/distro/poky.conf
2 2
3DISTRO_FEATURES_append = " sota"
4
3DISTRO = "poky-sota" 5DISTRO = "poky-sota"
4DISTRO_NAME = "OTA-enabled Linux" 6DISTRO_NAME = "OTA-enabled Linux"
5DISTRO_VERSION = "1.0" 7DISTRO_VERSION = "1.0"
@@ -8,5 +10,7 @@ DISTRO_CODENAME = "sota"
8DISTRO_FEATURES_append = " systemd" 10DISTRO_FEATURES_append = " systemd"
9VIRTUAL-RUNTIME_init_manager = "systemd" 11VIRTUAL-RUNTIME_init_manager = "systemd"
10 12
11INHERIT += " sota" 13INHERIT_prepend = " sota"
12IMAGE_INSTALL_append = " connman connman-client rvi-sota-client" 14IMAGE_INSTALL_append = " connman connman-client rvi-sota-client"
15
16USER_CLASSES_remove = "image-prelink"
diff --git a/conf/distro/poky-sota.conf b/conf/distro/poky-sota.conf
index 6972a94..c56695e 100644
--- a/conf/distro/poky-sota.conf
+++ b/conf/distro/poky-sota.conf
@@ -1,5 +1,7 @@
1require conf/distro/poky.conf 1require conf/distro/poky.conf
2 2
3DISTRO_FEATURES_append = " sota"
4
3DISTRO = "poky-sota" 5DISTRO = "poky-sota"
4DISTRO_NAME = "OTA-enabled Linux" 6DISTRO_NAME = "OTA-enabled Linux"
5DISTRO_VERSION = "1.0" 7DISTRO_VERSION = "1.0"
@@ -7,3 +9,4 @@ DISTRO_CODENAME = "sota"
7 9
8INHERIT += " sota" 10INHERIT += " sota"
9IMAGE_INSTALL_append = " connman connman-client" 11IMAGE_INSTALL_append = " connman connman-client"
12USER_CLASSES_remove = "image-prelink"
diff --git a/conf/include/bblayers/sota_porter.inc b/conf/include/bblayers/sota_porter.inc
index a0888d5..6964ef0 100644
--- a/conf/include/bblayers/sota_porter.inc
+++ b/conf/include/bblayers/sota_porter.inc
@@ -1,2 +1,2 @@
1 1
2BBLAYERS += " ${METADIR}/meta-updater-porter ${METADIR}/meta-renesas " 2BBLAYERS += " ${METADIR}/meta-renesas ${METADIR}/meta-renesas/meta-rcar-gen2 ${METADIR}/meta-openembedded/meta-multimedia ${METADIR}/meta-updater-porter"
diff --git a/recipes-bsp/grub/grub-efi_%.bbappend b/recipes-bsp/grub/grub-efi_%.bbappend
index 545e806..bebb006 100644
--- a/recipes-bsp/grub/grub-efi_%.bbappend
+++ b/recipes-bsp/grub/grub-efi_%.bbappend
@@ -1,2 +1,2 @@
1 1
2GRUB_BUILDIN += "configfile" 2GRUB_BUILDIN_append_sota = " configfile"
diff --git a/recipes-support/fuse/fuse_%.bbappend b/recipes-support/fuse/fuse_%.bbappend
index 4f23349..85bdf50 100644
--- a/recipes-support/fuse/fuse_%.bbappend
+++ b/recipes-support/fuse/fuse_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND = "native" 1BBCLASSEXTEND_append_sota = " native"
2 2
3PACKAGES_append_class-native = "fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native" 3PACKAGES_append_class-native_sota = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native', ' ', d)}"
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend
index d3267ac..fccb949 100644
--- a/recipes-support/glib-networking/glib-networking_%.bbappend
+++ b/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -1 +1 @@
BBCLASSEXTEND = "native" BBCLASSEXTEND_append_sota = " native"
diff --git a/recipes-support/gpgme/gpgme_%.bbappend b/recipes-support/gpgme/gpgme_%.bbappend
index d3267ac..27f258e 100644
--- a/recipes-support/gpgme/gpgme_%.bbappend
+++ b/recipes-support/gpgme/gpgme_%.bbappend
@@ -1 +1 @@
BBCLASSEXTEND = "native" BBCLASSEXTEND_append_sota = "native"
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend
index ed24273..ce4df6d 100644
--- a/recipes-support/libsoup/libsoup-2.4_%.bbappend
+++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND = "native" 1BBCLASSEXTEND_append_sota = " native"
2 2
3DEPENDS_append_class-native = " glib-networking-native" 3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}"
diff --git a/recipes-support/libssh2/libssh2_%.bbappend b/recipes-support/libssh2/libssh2_%.bbappend
index ce4807e..bebaf84 100644
--- a/recipes-support/libssh2/libssh2_%.bbappend
+++ b/recipes-support/libssh2/libssh2_%.bbappend
@@ -1,2 +1,2 @@
1# meta-oe/recipes-support/libssh2 1# meta-oe/recipes-support/libssh2
2BBCLASSEXTEND = "native" 2BBCLASSEXTEND_append_sota = " native"
diff --git a/recipes-support/util-linux/util-linux_%.bbappend b/recipes-support/util-linux/util-linux_%.bbappend
index bd3f686..d653bb2 100644
--- a/recipes-support/util-linux/util-linux_%.bbappend
+++ b/recipes-support/util-linux/util-linux_%.bbappend
@@ -1,10 +1,3 @@
1PACKAGES_append_class-native = "util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native \ 1PACKAGES_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native', ' ', d)}"
2 util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native \
3 util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native \
4 util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid \
5 util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native \
6 util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native \
7 util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock \
8 util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native \
9 ${@bb.utils.contains('PACKAGECONFIG', 'pylibmount', 'util-linux-pylibmount-native', '', d)}"
10 2
3PACKAGES_append_class-native = "${@' util-linux-pylibmount-native' if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d) and bb.utils.contains('PACKAGECONFIG', 'pylibmount', True, False, d) else ' '}"