diff options
-rw-r--r-- | lib/oeqa/selftest/updater.py | 9 | ||||
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 1 |
2 files changed, 9 insertions, 1 deletions
diff --git a/lib/oeqa/selftest/updater.py b/lib/oeqa/selftest/updater.py index adae081..13e1c21 100644 --- a/lib/oeqa/selftest/updater.py +++ b/lib/oeqa/selftest/updater.py | |||
@@ -19,13 +19,20 @@ class SotaToolsTests(oeSelfTest): | |||
19 | logger.info('Running bitbake to build aktualizr-native tools') | 19 | logger.info('Running bitbake to build aktualizr-native tools') |
20 | bitbake('aktualizr-native') | 20 | bitbake('aktualizr-native') |
21 | 21 | ||
22 | def test_help(self): | 22 | def test_push_help(self): |
23 | bb_vars = get_bb_vars(['SYSROOT_DESTDIR', 'bindir'], 'aktualizr-native') | 23 | bb_vars = get_bb_vars(['SYSROOT_DESTDIR', 'bindir'], 'aktualizr-native') |
24 | p = bb_vars['SYSROOT_DESTDIR'] + bb_vars['bindir'] + "/" + "garage-push" | 24 | p = bb_vars['SYSROOT_DESTDIR'] + bb_vars['bindir'] + "/" + "garage-push" |
25 | self.assertTrue(os.path.isfile(p), msg = "No garage-push found (%s)" % p) | 25 | self.assertTrue(os.path.isfile(p), msg = "No garage-push found (%s)" % p) |
26 | result = runCmd('%s --help' % p, ignore_status=True) | 26 | result = runCmd('%s --help' % p, ignore_status=True) |
27 | self.assertEqual(result.status, 0, "Status not equal to 0. output: %s" % result.output) | 27 | self.assertEqual(result.status, 0, "Status not equal to 0. output: %s" % result.output) |
28 | 28 | ||
29 | def test_deploy_help(self): | ||
30 | bb_vars = get_bb_vars(['SYSROOT_DESTDIR', 'bindir'], 'aktualizr-native') | ||
31 | p = bb_vars['SYSROOT_DESTDIR'] + bb_vars['bindir'] + "/" + "garage-deploy" | ||
32 | self.assertTrue(os.path.isfile(p), msg = "No garage-deploy found (%s)" % p) | ||
33 | result = runCmd('%s --help' % p, ignore_status=True) | ||
34 | self.assertEqual(result.status, 0, "Status not equal to 0. output: %s" % result.output) | ||
35 | |||
29 | 36 | ||
30 | class GarageSignTests(oeSelfTest): | 37 | class GarageSignTests(oeSelfTest): |
31 | 38 | ||
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index c98027d..7af7c60 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -47,5 +47,6 @@ FILES_${PN}_class-target = " \ | |||
47 | " | 47 | " |
48 | FILES_${PN}_class-native = " \ | 48 | FILES_${PN}_class-native = " \ |
49 | ${bindir}/aktualizr_implicit_writer \ | 49 | ${bindir}/aktualizr_implicit_writer \ |
50 | ${bindir}/garage-deploy \ | ||
50 | ${bindir}/garage-push \ | 51 | ${bindir}/garage-push \ |
51 | " | 52 | " |