diff options
-rw-r--r-- | lib/oeqa/selftest/cases/updater_qemux86_64.py | 16 | ||||
-rwxr-xr-x | recipes-sota/aktualizr/aktualizr_git.bb | 5 |
2 files changed, 11 insertions, 10 deletions
diff --git a/lib/oeqa/selftest/cases/updater_qemux86_64.py b/lib/oeqa/selftest/cases/updater_qemux86_64.py index bef6cdc..9f32bcf 100644 --- a/lib/oeqa/selftest/cases/updater_qemux86_64.py +++ b/lib/oeqa/selftest/cases/updater_qemux86_64.py | |||
@@ -341,11 +341,6 @@ class SecondaryTests(OESelftestTestCase): | |||
341 | self.assertEqual(retcode, 0, "Unable to run aktualizr-secondary --help") | 341 | self.assertEqual(retcode, 0, "Unable to run aktualizr-secondary --help") |
342 | self.assertEqual(stderr, b'', 'Error: ' + stderr.decode()) | 342 | self.assertEqual(stderr, b'', 'Error: ' + stderr.decode()) |
343 | 343 | ||
344 | def test_secondary_listening(self): | ||
345 | print('Checking aktualizr-secondary service is listening') | ||
346 | stdout, stderr, retcode = self.qemu_command('aktualizr-check-discovery') | ||
347 | self.assertEqual(retcode, 0, "Unable to connect to secondary") | ||
348 | |||
349 | 344 | ||
350 | class PrimaryTests(OESelftestTestCase): | 345 | class PrimaryTests(OESelftestTestCase): |
351 | def setUpLocal(self): | 346 | def setUpLocal(self): |
@@ -413,11 +408,18 @@ class ResourceControlTests(OESelftestTestCase): | |||
413 | 408 | ||
414 | def test_aktualizr_resource_control(self): | 409 | def test_aktualizr_resource_control(self): |
415 | print('Checking aktualizr was killed') | 410 | print('Checking aktualizr was killed') |
416 | stdout, stderr, retcode = self.qemu_command('systemctl --no-pager show aktualizr') | 411 | ran_ok = False |
412 | for delay in [5, 5, 5, 5]: | ||
413 | sleep(delay) | ||
414 | stdout, stderr, retcode = self.qemu_command('systemctl --no-pager show aktualizr') | ||
415 | if retcode == 0 and b'ExecMainStatus=9' in stdout: | ||
416 | ran_ok = True | ||
417 | break | ||
418 | self.assertTrue(ran_ok, 'Aktualizr was not killed') | ||
419 | |||
417 | self.assertIn(b'CPUWeight=1000', stdout, 'CPUWeight was not set correctly') | 420 | self.assertIn(b'CPUWeight=1000', stdout, 'CPUWeight was not set correctly') |
418 | self.assertIn(b'MemoryHigh=52428800', stdout, 'MemoryHigh was not set correctly') | 421 | self.assertIn(b'MemoryHigh=52428800', stdout, 'MemoryHigh was not set correctly') |
419 | self.assertIn(b'MemoryMax=1048576', stdout, 'MemoryMax was not set correctly') | 422 | self.assertIn(b'MemoryMax=1048576', stdout, 'MemoryMax was not set correctly') |
420 | self.assertIn(b'ExecMainStatus=9', stdout, 'Aktualizr was not killed') | ||
421 | 423 | ||
422 | self.qemu_command('systemctl --runtime set-property aktualizr MemoryMax=') | 424 | self.qemu_command('systemctl --runtime set-property aktualizr MemoryMax=') |
423 | self.qemu_command('systemctl restart aktualizr') | 425 | self.qemu_command('systemctl restart aktualizr') |
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 64382d8..c0e275d 100755 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -7,8 +7,7 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | |||
7 | 7 | ||
8 | DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" | 8 | DEPENDS = "boost curl openssl libarchive libsodium sqlite3 asn1c-native" |
9 | DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native ostree-native aktualizr-native ', '', d)}" | 9 | DEPENDS_append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' coreutils-native ostree-native aktualizr-native ', '', d)}" |
10 | RDEPENDS_${PN}_class-target = "aktualizr-check-discovery aktualizr-configs lshw" | 10 | RDEPENDS_${PN}_class-target = "aktualizr-configs lshw" |
11 | RDEPENDS_${PN}-secondary = "aktualizr-check-discovery" | ||
12 | RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-repo aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}" | 11 | RDEPENDS_${PN}-host-tools = "aktualizr aktualizr-repo aktualizr-cert-provider ${@bb.utils.contains('PACKAGECONFIG', 'sota-tools', 'garage-deploy garage-push', '', d)}" |
13 | 12 | ||
14 | RDEPENDS_${PN}-ptest += "bash cmake curl python3-modules openssl-bin sqlite3 valgrind" | 13 | RDEPENDS_${PN}-ptest += "bash cmake curl python3-modules openssl-bin sqlite3 valgrind" |
@@ -33,7 +32,7 @@ SRC_URI = " \ | |||
33 | SRC_URI[md5sum] = "c5e9968dfe78a7264ab9a8338c11725d" | 32 | SRC_URI[md5sum] = "c5e9968dfe78a7264ab9a8338c11725d" |
34 | SRC_URI[sha256sum] = "3a19258d7a1825a308aca0da82f7a337985bec05e8951355c4c95f0fcf2444f4" | 33 | SRC_URI[sha256sum] = "3a19258d7a1825a308aca0da82f7a337985bec05e8951355c4c95f0fcf2444f4" |
35 | 34 | ||
36 | SRCREV = "9c5ef10b7b91cc7d51cd22fc60446e734cf84690" | 35 | SRCREV = "c50feb37034eceb1254429d3e3ed38e5b8a0dc60" |
37 | BRANCH ?= "master" | 36 | BRANCH ?= "master" |
38 | 37 | ||
39 | S = "${WORKDIR}/git" | 38 | S = "${WORKDIR}/git" |