summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/libp11/libp11_git.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/recipes-support/libp11/libp11_git.bb b/recipes-support/libp11/libp11_git.bb
deleted file mode 100644
index e51bcce..0000000
--- a/recipes-support/libp11/libp11_git.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
5HOMEPAGE = "http://www.opensc-project.org/libp11"
6SECTION = "Development/Libraries"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
9DEPENDS = "libtool openssl"
10RDEPENDS_${PN} += " opensc"
11
12SRC_URI = "git://github.com/OpenSC/libp11.git \
13 file://0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch"
14SRCREV = "57ca68ff67efa08e3be1f26dec6d23bf5bb977f2"
15
16PV = "0.4.9+git${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
22# Currently, Makefile dependencies are incorrectly defined which causes build errors
23# if the number of jobs is high
24# See https://github.com/OpenSC/libp11/issues/94
25PARALLEL_MAKE = ""
26EXTRA_OECONF = "--disable-static"
27
28do_install_append () {
29 rm -rf ${D}${libdir}/*.la
30 rm -rf ${D}${docdir}/${BPN}
31}
32
33FILES_${PN} = "${libdir}/engines*/pkcs11.so \
34 ${libdir}/engines*/libpkcs11${SOLIBS} \
35 ${libdir}/libp11${SOLIBS}"
36
37FILES_${PN}-dev = " \
38 ${libdir}/engines*/libpkcs11${SOLIBSDEV} \
39 ${libdir}/libp11${SOLIBSDEV} \
40 ${libdir}/pkgconfig/libp11.pc \
41 /usr/include"