summaryrefslogtreecommitdiffstats
path: root/recipes-test
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2020-08-03 08:58:53 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2020-08-26 09:47:38 +0200
commit2d882d62feef02a7a4d28738ce595181f301dcd7 (patch)
treee50cba441aeb1d03f0b407218930c658e7c47ac7 /recipes-test
parenta753c2409f71ec9614ec48ade330c96a1cb919bc (diff)
downloadmeta-updater-2d882d62feef02a7a4d28738ce595181f301dcd7.tar.gz
Inherit python3native instead of using HOSTTOOLS.
Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-test')
-rw-r--r--recipes-test/big-update/big-update_1.0.bb2
-rw-r--r--recipes-test/big-update/big-update_2.0.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes-test/big-update/big-update_1.0.bb b/recipes-test/big-update/big-update_1.0.bb
index 3b1d652..dfb3a96 100644
--- a/recipes-test/big-update/big-update_1.0.bb
+++ b/recipes-test/big-update/big-update_1.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 10M)
diff --git a/recipes-test/big-update/big-update_2.0.bb b/recipes-test/big-update/big-update_2.0.bb
index 7cb6e94..6fffbc1 100644
--- a/recipes-test/big-update/big-update_2.0.bb
+++ b/recipes-test/big-update/big-update_2.0.bb
@@ -7,6 +7,8 @@ FILES_${PN} = "/usr/lib/big-update"
7 7
8DEPENDS = "coreutils-native" 8DEPENDS = "coreutils-native"
9 9
10inherit python3native
11
10do_install() { 12do_install() {
11 install -d ${D}/usr/lib/big-update 13 install -d ${D}/usr/lib/big-update
12 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M) 14 python ${S}/../rand_file.py ${D}/usr/lib/big-update/a-big-file $(numfmt --from=iec 12M)