diff options
author | Mykhaylo Sul <ext-mykhaylo.sul@here.com> | 2020-01-03 11:36:09 +0100 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2020-01-20 09:03:33 +0100 |
commit | bbc4cc32859e60f3c6bb9bd8a06776e65404f134 (patch) | |
tree | 7e7f2d008e7a455a5c924ea35d214d79b8fd328c /recipes-test | |
parent | 56d4502f9055616d09ec49beaf64bd54299858c3 (diff) | |
download | meta-updater-bbc4cc32859e60f3c6bb9bd8a06776e65404f134.tar.gz |
OTA-4174: Make an ostree update a default on IP Secondary
Signed-off-by: Mykhaylo Sul <ext-mykhaylo.sul@here.com>
Diffstat (limited to 'recipes-test')
-rw-r--r-- | recipes-test/demo-config/files/30-fake-pacman.toml | 2 | ||||
-rw-r--r-- | recipes-test/demo-config/files/30-ostree-pacman.toml | 2 | ||||
-rw-r--r-- | recipes-test/demo-config/secondary-config.bb | 6 |
3 files changed, 5 insertions, 5 deletions
diff --git a/recipes-test/demo-config/files/30-fake-pacman.toml b/recipes-test/demo-config/files/30-fake-pacman.toml deleted file mode 100644 index 3fb5cf2..0000000 --- a/recipes-test/demo-config/files/30-fake-pacman.toml +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | [pacman] | ||
2 | type = "fake" | ||
diff --git a/recipes-test/demo-config/files/30-ostree-pacman.toml b/recipes-test/demo-config/files/30-ostree-pacman.toml new file mode 100644 index 0000000..d2cf5b8 --- /dev/null +++ b/recipes-test/demo-config/files/30-ostree-pacman.toml | |||
@@ -0,0 +1,2 @@ | |||
1 | [pacman] | ||
2 | type = "ostree" | ||
diff --git a/recipes-test/demo-config/secondary-config.bb b/recipes-test/demo-config/secondary-config.bb index ddbed89..58b18df 100644 --- a/recipes-test/demo-config/secondary-config.bb +++ b/recipes-test/demo-config/secondary-config.bb | |||
@@ -12,14 +12,14 @@ SOTA_HARDWARE_ID ?= "${MACHINE}-sndry" | |||
12 | SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" | 12 | SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" |
13 | 13 | ||
14 | SRC_URI = "\ | 14 | SRC_URI = "\ |
15 | file://30-fake-pacman.toml \ | 15 | file://30-ostree-pacman.toml \ |
16 | file://35-network-config.toml \ | 16 | file://35-network-config.toml \ |
17 | file://45-id-config.toml \ | 17 | file://45-id-config.toml \ |
18 | " | 18 | " |
19 | 19 | ||
20 | do_install () { | 20 | do_install () { |
21 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 21 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
22 | install -m 0644 ${WORKDIR}/30-fake-pacman.toml ${D}${libdir}/sota/conf.d/30-fake-pacman.toml | 22 | install -m 0644 ${WORKDIR}/30-ostree-pacman.toml ${D}${libdir}/sota/conf.d/30-ostree-pacman.toml |
23 | 23 | ||
24 | install -m 0644 ${WORKDIR}/35-network-config.toml ${D}${libdir}/sota/conf.d/35-network-config.toml | 24 | install -m 0644 ${WORKDIR}/35-network-config.toml ${D}${libdir}/sota/conf.d/35-network-config.toml |
25 | sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \ | 25 | sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \ |
@@ -36,7 +36,7 @@ do_install () { | |||
36 | 36 | ||
37 | FILES_${PN} = " \ | 37 | FILES_${PN} = " \ |
38 | ${libdir}/sota/conf.d \ | 38 | ${libdir}/sota/conf.d \ |
39 | ${libdir}/sota/conf.d/30-fake-pacman.toml \ | 39 | ${libdir}/sota/conf.d/30-ostree-pacman.toml \ |
40 | ${libdir}/sota/conf.d/35-network-config.toml \ | 40 | ${libdir}/sota/conf.d/35-network-config.toml \ |
41 | ${libdir}/sota/conf.d/45-id-config.toml \ | 41 | ${libdir}/sota/conf.d/45-id-config.toml \ |
42 | " | 42 | " |