diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2019-05-28 09:46:28 +0200 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2019-06-05 11:55:41 +0200 |
commit | ecd33302096d269953b52d75b21225778263e27a (patch) | |
tree | 41c15ddb5e90e9b49acc78384bae2cc4dcd814d6 /recipes-test | |
parent | eb63622b2f3aa4869e0a4e927b5b2ee5bd152053 (diff) | |
download | meta-updater-ecd33302096d269953b52d75b21225778263e27a.tar.gz |
Rename provisioning methods.
"Autoprovisioning" or "automatic provisioning" is now known as "shared
credential provisioning". "Implicit provisioning" is now known as
"device credential provisioning". "HSM provisioning" was always a
misnomer, so it is now refered to as "device credential provisioning
with an HSM".
This includes a bump of the aktualizr version as well.
Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-test')
-rw-r--r-- | recipes-test/demo-config/files/30-fake-pacman.toml (renamed from recipes-test/demo-config/files/30-fake_pacman.toml) | 0 | ||||
-rw-r--r-- | recipes-test/demo-config/files/30-secondary-config.toml (renamed from recipes-test/demo-config/files/30-secondary_config.toml) | 0 | ||||
-rw-r--r-- | recipes-test/demo-config/files/35-network-config.toml (renamed from recipes-test/demo-config/files/35-network_config.toml) | 0 | ||||
-rw-r--r-- | recipes-test/demo-config/files/45-id-config.toml (renamed from recipes-test/demo-config/files/45-id_config.toml) | 0 | ||||
-rw-r--r-- | recipes-test/demo-config/primary-config.bb | 6 | ||||
-rw-r--r-- | recipes-test/demo-config/secondary-config.bb | 22 | ||||
-rw-r--r-- | recipes-test/images/secondary-image.bb | 10 |
7 files changed, 19 insertions, 19 deletions
diff --git a/recipes-test/demo-config/files/30-fake_pacman.toml b/recipes-test/demo-config/files/30-fake-pacman.toml index 3fb5cf2..3fb5cf2 100644 --- a/recipes-test/demo-config/files/30-fake_pacman.toml +++ b/recipes-test/demo-config/files/30-fake-pacman.toml | |||
diff --git a/recipes-test/demo-config/files/30-secondary_config.toml b/recipes-test/demo-config/files/30-secondary-config.toml index 7714240..7714240 100644 --- a/recipes-test/demo-config/files/30-secondary_config.toml +++ b/recipes-test/demo-config/files/30-secondary-config.toml | |||
diff --git a/recipes-test/demo-config/files/35-network_config.toml b/recipes-test/demo-config/files/35-network-config.toml index db7a1bb..db7a1bb 100644 --- a/recipes-test/demo-config/files/35-network_config.toml +++ b/recipes-test/demo-config/files/35-network-config.toml | |||
diff --git a/recipes-test/demo-config/files/45-id_config.toml b/recipes-test/demo-config/files/45-id-config.toml index 6cbd77f..6cbd77f 100644 --- a/recipes-test/demo-config/files/45-id_config.toml +++ b/recipes-test/demo-config/files/45-id-config.toml | |||
diff --git a/recipes-test/demo-config/primary-config.bb b/recipes-test/demo-config/primary-config.bb index 0cd9180..27cb553 100644 --- a/recipes-test/demo-config/primary-config.bb +++ b/recipes-test/demo-config/primary-config.bb | |||
@@ -7,7 +7,7 @@ require shared-conf.inc | |||
7 | PRIMARY_SECONDARIES ?= "${SECONDARY_IP}:${SECONDARY_PORT}" | 7 | PRIMARY_SECONDARIES ?= "${SECONDARY_IP}:${SECONDARY_PORT}" |
8 | 8 | ||
9 | SRC_URI = "\ | 9 | SRC_URI = "\ |
10 | file://30-secondary_config.toml \ | 10 | file://30-secondary-config.toml \ |
11 | file://ip_secondary_config.json \ | 11 | file://ip_secondary_config.json \ |
12 | " | 12 | " |
13 | 13 | ||
@@ -56,8 +56,8 @@ do_install () { | |||
56 | 56 | ||
57 | # install aktualizr config file (toml) that points to the secondary config file, so aktualizr is aware about it | 57 | # install aktualizr config file (toml) that points to the secondary config file, so aktualizr is aware about it |
58 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 58 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
59 | install -m 0644 ${WORKDIR}/30-secondary_config.toml ${D}${libdir}/sota/conf.d | 59 | install -m 0644 ${WORKDIR}/30-secondary-config.toml ${D}${libdir}/sota/conf.d |
60 | sed -i "s|@CFG_FILEPATH@|$SECONDARY_CONFIG_FILEPATH_ON_IMAGE|g" ${D}${libdir}/sota/conf.d/30-secondary_config.toml | 60 | sed -i "s|@CFG_FILEPATH@|$SECONDARY_CONFIG_FILEPATH_ON_IMAGE|g" ${D}${libdir}/sota/conf.d/30-secondary-config.toml |
61 | } | 61 | } |
62 | 62 | ||
63 | FILES_${PN} = " \ | 63 | FILES_${PN} = " \ |
diff --git a/recipes-test/demo-config/secondary-config.bb b/recipes-test/demo-config/secondary-config.bb index 5b213d1..9411646 100644 --- a/recipes-test/demo-config/secondary-config.bb +++ b/recipes-test/demo-config/secondary-config.bb | |||
@@ -9,33 +9,33 @@ SOTA_HARDWARE_ID ?= "${MACHINE}-sndry" | |||
9 | SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" | 9 | SECONDARY_HARDWARE_ID ?= "${SOTA_HARDWARE_ID}" |
10 | 10 | ||
11 | SRC_URI = "\ | 11 | SRC_URI = "\ |
12 | file://30-fake_pacman.toml \ | 12 | file://30-fake-pacman.toml \ |
13 | file://35-network_config.toml \ | 13 | file://35-network-config.toml \ |
14 | file://45-id_config.toml \ | 14 | file://45-id-config.toml \ |
15 | " | 15 | " |
16 | 16 | ||
17 | do_install () { | 17 | do_install () { |
18 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 18 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
19 | install -m 0644 ${WORKDIR}/30-fake_pacman.toml ${D}/${libdir}/sota/conf.d/30-fake_pacman.toml | 19 | install -m 0644 ${WORKDIR}/30-fake-pacman.toml ${D}/${libdir}/sota/conf.d/30-fake-pacman.toml |
20 | 20 | ||
21 | install -m 0644 ${WORKDIR}/35-network_config.toml ${D}/${libdir}/sota/conf.d/35-network_config.toml | 21 | install -m 0644 ${WORKDIR}/35-network-config.toml ${D}/${libdir}/sota/conf.d/35-network-config.toml |
22 | sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \ | 22 | sed -i -e 's|@PORT@|${SECONDARY_PORT}|g' \ |
23 | -e 's|@PRIMARY_IP@|${PRIMARY_IP}|g' \ | 23 | -e 's|@PRIMARY_IP@|${PRIMARY_IP}|g' \ |
24 | -e 's|@PRIMARY_PORT@|${PRIMARY_PORT}|g' \ | 24 | -e 's|@PRIMARY_PORT@|${PRIMARY_PORT}|g' \ |
25 | ${D}/${libdir}/sota/conf.d/35-network_config.toml | 25 | ${D}/${libdir}/sota/conf.d/35-network-config.toml |
26 | 26 | ||
27 | install -m 0644 ${WORKDIR}/45-id_config.toml ${D}/${libdir}/sota/conf.d/45-id_config.toml | 27 | install -m 0644 ${WORKDIR}/45-id-config.toml ${D}/${libdir}/sota/conf.d/45-id-config.toml |
28 | sed -i -e 's|@SERIAL@|${SECONDARY_SERIAL_ID}|g' \ | 28 | sed -i -e 's|@SERIAL@|${SECONDARY_SERIAL_ID}|g' \ |
29 | -e 's|@HWID@|${SECONDARY_HARDWARE_ID}|g' \ | 29 | -e 's|@HWID@|${SECONDARY_HARDWARE_ID}|g' \ |
30 | ${D}/${libdir}/sota/conf.d/45-id_config.toml | 30 | ${D}/${libdir}/sota/conf.d/45-id-config.toml |
31 | 31 | ||
32 | } | 32 | } |
33 | 33 | ||
34 | FILES_${PN} = " \ | 34 | FILES_${PN} = " \ |
35 | ${libdir}/sota/conf.d \ | 35 | ${libdir}/sota/conf.d \ |
36 | ${libdir}/sota/conf.d/30-fake_pacman.toml \ | 36 | ${libdir}/sota/conf.d/30-fake-pacman.toml \ |
37 | ${libdir}/sota/conf.d/35-network_config.toml \ | 37 | ${libdir}/sota/conf.d/35-network-config.toml \ |
38 | ${libdir}/sota/conf.d/45-id_config.toml \ | 38 | ${libdir}/sota/conf.d/45-id-config.toml \ |
39 | " | 39 | " |
40 | 40 | ||
41 | # vim:set ts=4 sw=4 sts=4 expandtab: | 41 | # vim:set ts=4 sw=4 sts=4 expandtab: |
diff --git a/recipes-test/images/secondary-image.bb b/recipes-test/images/secondary-image.bb index 4cae874..27d1e3f 100644 --- a/recipes-test/images/secondary-image.bb +++ b/recipes-test/images/secondary-image.bb | |||
@@ -11,11 +11,11 @@ SOTA_HARDWARE_ID ?= "${MACHINE}-sndry" | |||
11 | # RDEPENDS on aktualizr) | 11 | # RDEPENDS on aktualizr) |
12 | IMAGE_INSTALL_remove = " \ | 12 | IMAGE_INSTALL_remove = " \ |
13 | aktualizr \ | 13 | aktualizr \ |
14 | aktualizr-auto-prov \ | 14 | aktualizr-shared-prov \ |
15 | aktualizr-auto-prov-creds \ | 15 | aktualizr-shared-prov-creds \ |
16 | aktualizr-ca-implicit-prov \ | 16 | aktualizr-device-prov \ |
17 | aktualizr-ca-implicit-prov-creds \ | 17 | aktualizr-device-prov-creds \ |
18 | aktualizr-hsm-prov \ | 18 | aktualizr-device-prov-hsm \ |
19 | aktualizr-uboot-env-rollback \ | 19 | aktualizr-uboot-env-rollback \ |
20 | virtual/network-configuration \ | 20 | virtual/network-configuration \ |
21 | " | 21 | " |