summaryrefslogtreecommitdiffstats
path: root/recipes-test/images/secondary-image.bb
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2018-03-29 13:45:30 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2018-05-28 11:10:57 +0200
commit4b33b1ac46fb525941c588b0a4c1b3ce132cad71 (patch)
tree244af48911d34ebc10ff12c35d1f107755666393 /recipes-test/images/secondary-image.bb
parent4bcd0509c780a2e244aab4713926a548c176fb5f (diff)
downloadmeta-updater-4b33b1ac46fb525941c588b0a4c1b3ce132cad71.tar.gz
Try to set hardware IDs in local.conf.bugfix/PRO-5140/hardware_ids
Communicating the IDs to the images works, but getting the IDs in the garage-push commits does not. I can get the variables exported, but the script still uses the wrong (old) value. Not sure why.
Diffstat (limited to 'recipes-test/images/secondary-image.bb')
-rw-r--r--recipes-test/images/secondary-image.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-test/images/secondary-image.bb b/recipes-test/images/secondary-image.bb
index 9adbdc5..75deb5a 100644
--- a/recipes-test/images/secondary-image.bb
+++ b/recipes-test/images/secondary-image.bb
@@ -1,9 +1,22 @@
1include recipes-core/images/core-image-minimal.bb 1include recipes-core/images/core-image-minimal.bb
2 2
3export SOTA_SECONDARY_HARDWARE_ID
4export SOTA_HARDWARE_ID
5
3SUMMARY = "A minimal Uptane Secondary image running aktualizr-secondary" 6SUMMARY = "A minimal Uptane Secondary image running aktualizr-secondary"
4 7
5LICENSE = "MIT" 8LICENSE = "MIT"
6 9
10IMAGE_TYPEDEP_garagesign_append = " set_hardware_id "
11IMAGE_CMD_set_hardware_id() {
12 if [ -n "${SOTA_SECONDARY_HARDWARE_ID}" ]; then
13 SOTA_HARDWARE_ID="${SOTA_SECONDARY_HARDWARE_ID}"
14 fi
15}
16#python IMAGE_CMD_set_hardware_id() {
17# if d.getVar("SOTA_SECONDARY_HARDWARE_ID", True):
18# d.setVar("SOTA_HARDWARE_ID", d.getVar("SOTA_SECONDARY_HARDWARE_ID", True))
19#}
7 20
8# Remove default aktualizr primary, and the provisioning configuration (which 21# Remove default aktualizr primary, and the provisioning configuration (which
9# RDEPENDS on aktualizr) 22# RDEPENDS on aktualizr)
@@ -19,6 +32,7 @@ IMAGE_INSTALL_remove = " \
19 32
20IMAGE_INSTALL_append = " \ 33IMAGE_INSTALL_append = " \
21 aktualizr-secondary \ 34 aktualizr-secondary \
35 aktualizr-secondary-conf \
22 secondary-network-config \ 36 secondary-network-config \
23 " 37 "
24 38