diff options
author | Mike Sul <ext-mykhaylo.sul@here.com> | 2019-05-21 08:04:44 +0300 |
---|---|---|
committer | Mike Sul <ext-mykhaylo.sul@here.com> | 2019-05-27 10:40:00 +0300 |
commit | d0b6547fde5038cb7ab9837681ea370af24de855 (patch) | |
tree | bbe7d483d6cb7e3804b1cd524b8d691ea02b29b4 /recipes-test/demo-network-config | |
parent | 753f664541c84f1977f370690e38d9130bf9e2f1 (diff) | |
download | meta-updater-d0b6547fde5038cb7ab9837681ea370af24de855.tar.gz |
OTA-2541: Add suffix '-sndry' to a default HW_ID for Secondary. Ability to define IP and Port in local.conf
Signed-off-by: Mike Sul <ext-mykhaylo.sul@here.com>
Diffstat (limited to 'recipes-test/demo-network-config')
3 files changed, 7 insertions, 5 deletions
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb index ce19f07..9725898 100644 --- a/recipes-test/demo-network-config/primary-network-config.bb +++ b/recipes-test/demo-network-config/primary-network-config.bb | |||
@@ -16,7 +16,8 @@ do_install() { | |||
16 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/ | 16 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/ |
17 | } | 17 | } |
18 | 18 | ||
19 | SECONDARY_NETWORK_IP_ADDR ?= "10.0.3.1" | 19 | PRIMARY_IP ?= "10.0.3.1" |
20 | IP_ADDR = "${PRIMARY_IP}" | ||
20 | 21 | ||
21 | require static-network-config.inc | 22 | require static-network-config.inc |
22 | 23 | ||
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb index 6473e05..e33229d 100644 --- a/recipes-test/demo-network-config/secondary-network-config.bb +++ b/recipes-test/demo-network-config/secondary-network-config.bb | |||
@@ -20,7 +20,8 @@ do_install() { | |||
20 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/ | 20 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/ |
21 | } | 21 | } |
22 | 22 | ||
23 | SECONDARY_NETWORK_IP_ADDR ?= "10.0.3.2" | 23 | SECONDARY_IP ?= "10.0.3.2" |
24 | IP_ADDR = "${SECONDARY_IP}" | ||
24 | 25 | ||
25 | require static-network-config.inc | 26 | require static-network-config.inc |
26 | 27 | ||
diff --git a/recipes-test/demo-network-config/static-network-config.inc b/recipes-test/demo-network-config/static-network-config.inc index 27d2a20..e64675e 100644 --- a/recipes-test/demo-network-config/static-network-config.inc +++ b/recipes-test/demo-network-config/static-network-config.inc | |||
@@ -2,13 +2,13 @@ SRC_URI_append = "\ | |||
2 | file://26-static-client.network \ | 2 | file://26-static-client.network \ |
3 | " | 3 | " |
4 | 4 | ||
5 | SECONDARY_NETWORK_INTERFACE_NAME ?= "enp0s5" | 5 | SECONDARY_INTERFACE ?= "enp0s5" |
6 | 6 | ||
7 | do_install_append() { | 7 | do_install_append() { |
8 | install -d ${D}/usr/lib/systemd/network | 8 | install -d ${D}/usr/lib/systemd/network |
9 | install -m 0644 ${WORKDIR}/26-static-client.network ${D}/usr/lib/systemd/network/ | 9 | install -m 0644 ${WORKDIR}/26-static-client.network ${D}/usr/lib/systemd/network/ |
10 | sed -i -e 's|@ADDR@|${SECONDARY_NETWORK_IP_ADDR}|g' \ | 10 | sed -i -e 's|@ADDR@|${IP_ADDR}|g' \ |
11 | -e 's|@IFNAME@|${SECONDARY_NETWORK_INTERFACE_NAME}|g' \ | 11 | -e 's|@IFNAME@|${SECONDARY_INTERFACE}|g' \ |
12 | ${D}/usr/lib/systemd/network/26-static-client.network | 12 | ${D}/usr/lib/systemd/network/26-static-client.network |
13 | 13 | ||
14 | } | 14 | } |