diff options
author | Mykhaylo Sul <ext-mykhaylo.sul@here.com> | 2020-02-07 10:09:56 +0100 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2020-02-28 13:43:34 +0100 |
commit | c6154200e06686c46df18eecd2d60e6b2f3789f4 (patch) | |
tree | 474186701aca1da45b8270a0b79ad1f1e200eab8 /recipes-test/demo-network-config | |
parent | 1cf84956442108d2c6713a12b9fe0a5bfe07536e (diff) | |
download | meta-updater-c6154200e06686c46df18eecd2d60e6b2f3789f4.tar.gz |
fix: make secondaries' network less intrusive
Signed-off-by: Mykhaylo Sul <ext-mykhaylo.sul@here.com>
Diffstat (limited to 'recipes-test/demo-network-config')
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes-test/demo-network-config/files/25-dhcp-server.network b/recipes-test/demo-network-config/files/25-dhcp-server.network index 4766f9a..03bb302 100644 --- a/recipes-test/demo-network-config/files/25-dhcp-server.network +++ b/recipes-test/demo-network-config/files/25-dhcp-server.network | |||
@@ -4,9 +4,9 @@ Name=enp0s4 | |||
4 | [Network] | 4 | [Network] |
5 | Description=Private internal network between aktualizr Primary and Secondary nodes | 5 | Description=Private internal network between aktualizr Primary and Secondary nodes |
6 | DHCPServer=yes | 6 | DHCPServer=yes |
7 | Address=10.0.3.1/24 | 7 | Address=192.168.254.1/24 |
8 | IPForward=yes | 8 | IPForward=yes |
9 | IPMasquerade=yes | 9 | IPMasquerade=yes |
10 | 10 | ||
11 | [DHCPServer] | 11 | [DHCPServer] |
12 | PoolOffset=10 \ No newline at end of file | 12 | PoolOffset=10 |
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb index 544a5ec..7ee873f 100644 --- a/recipes-test/demo-network-config/primary-network-config.bb +++ b/recipes-test/demo-network-config/primary-network-config.bb | |||
@@ -15,7 +15,7 @@ do_install() { | |||
15 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/ | 15 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/ |
16 | } | 16 | } |
17 | 17 | ||
18 | PRIMARY_IP ?= "10.0.3.1" | 18 | PRIMARY_IP ?= "192.168.254.1" |
19 | 19 | ||
20 | IP_ADDR = "${PRIMARY_IP}" | 20 | IP_ADDR = "${PRIMARY_IP}" |
21 | CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}" | 21 | CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}" |
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb index 66641c3..b268cd3 100644 --- a/recipes-test/demo-network-config/secondary-network-config.bb +++ b/recipes-test/demo-network-config/secondary-network-config.bb | |||
@@ -19,7 +19,7 @@ do_install() { | |||
19 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/ | 19 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}${libdir}/systemd/network/ |
20 | } | 20 | } |
21 | 21 | ||
22 | SECONDARY_IP ?= "10.0.3.2" | 22 | SECONDARY_IP ?= "192.168.254.2" |
23 | IP_ADDR = "${SECONDARY_IP}" | 23 | IP_ADDR = "${SECONDARY_IP}" |
24 | CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}" | 24 | CONF_TYPE ?= "${@ 'multihomed' if d.getVar('MACHINE') == 'raspberrypi3' and d.getVar('RPI_WIFI_ENABLE') != '1' else 'static'}" |
25 | 25 | ||