diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2019-05-27 14:59:14 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2019-05-27 14:59:14 +0200 |
commit | d1291df592cd0ea20a61b21228d45995e1766458 (patch) | |
tree | 1232bb0041816dffc09f3e118356b018725c161e /recipes-test/demo-network-config/secondary-network-config.bb | |
parent | a6c241c31f0afbf762a230db4b92c1758db66158 (diff) | |
parent | 8e9bbe95badbc889f3cd69caff8a223f65e6042d (diff) | |
download | meta-updater-d1291df592cd0ea20a61b21228d45995e1766458.tar.gz |
Merge pull request #520 from advancedtelematic/feat/OTA-2541/preconfigured-secondaries
Posix/IP Secondary and Primary Support
Diffstat (limited to 'recipes-test/demo-network-config/secondary-network-config.bb')
-rw-r--r-- | recipes-test/demo-network-config/secondary-network-config.bb | 17 |
1 files changed, 13 insertions, 4 deletions
diff --git a/recipes-test/demo-network-config/secondary-network-config.bb b/recipes-test/demo-network-config/secondary-network-config.bb index 9091c65..c70d88a 100644 --- a/recipes-test/demo-network-config/secondary-network-config.bb +++ b/recipes-test/demo-network-config/secondary-network-config.bb | |||
@@ -1,20 +1,29 @@ | |||
1 | DESCRIPTION = "Sample network configuration for an Uptane Secondary" | 1 | DESCRIPTION = "Sample network configuration for an Uptane Secondary" |
2 | LICENSE = "CLOSED" | 2 | LICENSE = "MPL-2.0" |
3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad" | ||
3 | 4 | ||
4 | inherit allarch | 5 | inherit allarch |
5 | 6 | ||
7 | # TODO: It configures the 'user' interface in NAT mode and provides an access to public Inet via it | ||
8 | # which is not desired for Secondary. It cannot be just removed since we get SSH access to Secondary | ||
9 | # VM via this interface. So, the task is to configure the interface in such way that it does provide access | ||
10 | # via SSH from a host machine and forbids an access to Inet | ||
6 | SRC_URI = "\ | 11 | SRC_URI = "\ |
7 | file://26-dhcp-client.network \ | ||
8 | file://27-dhcp-client-external.network \ | 12 | file://27-dhcp-client-external.network \ |
9 | " | 13 | " |
10 | 14 | ||
11 | |||
12 | FILES_${PN} = "/usr/lib/systemd/network" | 15 | FILES_${PN} = "/usr/lib/systemd/network" |
13 | 16 | ||
14 | PR = "1" | 17 | PR = "1" |
15 | 18 | ||
16 | do_install() { | 19 | do_install() { |
17 | install -d ${D}/usr/lib/systemd/network | 20 | install -d ${D}/usr/lib/systemd/network |
18 | install -m 0644 ${WORKDIR}/26-dhcp-client.network ${D}/usr/lib/systemd/network/ | ||
19 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/ | 21 | install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/ |
20 | } | 22 | } |
23 | |||
24 | SECONDARY_IP ?= "10.0.3.2" | ||
25 | IP_ADDR = "${SECONDARY_IP}" | ||
26 | |||
27 | require static-network-config.inc | ||
28 | |||
29 | # vim:set ts=4 sw=4 sts=4 expandtab: | ||