summaryrefslogtreecommitdiffstats
path: root/recipes-test/demo-network-config/primary-network-config.bb
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2019-05-27 14:59:14 +0200
committerGitHub <noreply@github.com>2019-05-27 14:59:14 +0200
commitd1291df592cd0ea20a61b21228d45995e1766458 (patch)
tree1232bb0041816dffc09f3e118356b018725c161e /recipes-test/demo-network-config/primary-network-config.bb
parenta6c241c31f0afbf762a230db4b92c1758db66158 (diff)
parent8e9bbe95badbc889f3cd69caff8a223f65e6042d (diff)
downloadmeta-updater-d1291df592cd0ea20a61b21228d45995e1766458.tar.gz
Merge pull request #520 from advancedtelematic/feat/OTA-2541/preconfigured-secondaries
Posix/IP Secondary and Primary Support
Diffstat (limited to 'recipes-test/demo-network-config/primary-network-config.bb')
-rw-r--r--recipes-test/demo-network-config/primary-network-config.bb17
1 files changed, 13 insertions, 4 deletions
diff --git a/recipes-test/demo-network-config/primary-network-config.bb b/recipes-test/demo-network-config/primary-network-config.bb
index 78678a2..c7daa15 100644
--- a/recipes-test/demo-network-config/primary-network-config.bb
+++ b/recipes-test/demo-network-config/primary-network-config.bb
@@ -1,10 +1,12 @@
1DESCRIPTION = "Sample network configuration for an Uptane Primary" 1DESCRIPTION = "Sample network configuration for an Uptane Primary"
2LICENSE = "CLOSED" 2LICENSE = "MPL-2.0"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
3 4
4inherit allarch 5inherit allarch
5 6
6SRC_URI = "file://25-dhcp-server.network" 7SRC_URI = "\
7 8 file://27-dhcp-client-external.network \
9 "
8 10
9FILES_${PN} = "/usr/lib/systemd/network" 11FILES_${PN} = "/usr/lib/systemd/network"
10 12
@@ -12,5 +14,12 @@ PR = "1"
12 14
13do_install() { 15do_install() {
14 install -d ${D}/usr/lib/systemd/network 16 install -d ${D}/usr/lib/systemd/network
15 install -m 0644 ${WORKDIR}/25-dhcp-server.network ${D}/usr/lib/systemd/network/ 17 install -m 0644 ${WORKDIR}/27-dhcp-client-external.network ${D}/usr/lib/systemd/network/
16} 18}
19
20PRIMARY_IP ?= "10.0.3.1"
21IP_ADDR = "${PRIMARY_IP}"
22
23require static-network-config.inc
24
25# vim:set ts=4 sw=4 sts=4 expandtab: