summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-07-04 16:08:15 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2017-07-04 16:08:15 +0200
commite39692a25858acf79fedf44b9d9fdd8e71337957 (patch)
tree8057661467ed37db9f567f04af49a56949a84376 /recipes-support
parent00cf945345a981e9cae155f66bda99e650eb6bf2 (diff)
downloadmeta-updater-e39692a25858acf79fedf44b9d9fdd8e71337957.tar.gz
Fix build issues with yocto pyro
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/glib-networking/glib-networking_%.bbappend7
-rw-r--r--recipes-support/libsoup/libsoup-2.4_%.bbappend2
2 files changed, 7 insertions, 2 deletions
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend
index fccb949..1c4fe19 100644
--- a/recipes-support/glib-networking/glib-networking_%.bbappend
+++ b/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -1 +1,6 @@
1BBCLASSEXTEND_append_sota = " native" 1BBCLASSEXTEND_append_sota = " native nativesdk"
2
3# Hackery to prevent relocatable_native_pcfiles from crashing
4do_install_append_class-native () {
5 rmdir ${D}${libdir}/pkgconfig
6}
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend
index ce4df6d..18383f1 100644
--- a/recipes-support/libsoup/libsoup-2.4_%.bbappend
+++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND_append_sota = " native" 1BBCLASSEXTEND_append_sota = " native nativesdk"
2 2
3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" 3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}"