summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-02-20 17:27:50 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2017-02-20 17:27:50 +0100
commitd47d19a199528a22f40f9a70e945822b9ac28197 (patch)
tree894c014a18b5c74ad611375f70873eb730318857 /recipes-support
parent0dab1e2af9b30cb8a07cac92d5832019c3973101 (diff)
downloadmeta-updater-d47d19a199528a22f40f9a70e945822b9ac28197.tar.gz
Fix a bug with missing GNU_HASH in lshw under Yocto
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/lshw/files/ldflags.patch42
-rw-r--r--recipes-support/lshw/lshw_02.16.bb3
2 files changed, 44 insertions, 1 deletions
diff --git a/recipes-support/lshw/files/ldflags.patch b/recipes-support/lshw/files/ldflags.patch
new file mode 100644
index 0000000..83e0410
--- /dev/null
+++ b/recipes-support/lshw/files/ldflags.patch
@@ -0,0 +1,42 @@
1diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.16/src/Makefile
2--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100
3+++ lshw-B.02.16/src/Makefile 2017-02-07 16:22:45.578588072 +0100
4@@ -25,9 +25,9 @@
5 ifeq ($(SQLITE), 1)
6 CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
7 endif
8-LDFLAGS=-L./core/ -g
9+LDEXTRAS=-L./core/ -g
10 ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
11- LDFLAGS+= -Wl,--as-needed
12+ LDEXTRAS+= -Wl,--as-needed
13 endif
14 LDSTATIC=-static
15 LIBS=-llshw -lresolv
16@@ -37,7 +37,7 @@
17
18 export CXXFLAGS
19 export LIBS
20-export LDFLAGS
21+export LDEXTRAS
22
23 DATAFILES = pci.ids usb.ids oui.txt manuf.txt
24
25@@ -51,7 +51,7 @@
26 +make -C core all
27
28 $(PACKAGENAME): core $(PACKAGENAME).o
29- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
30+ $(CXX) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
31
32 .PHONY: po
33 po:
34@@ -69,7 +69,7 @@
35 static: $(PACKAGENAME)-static
36
37 $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
38- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
39+ $(CXX) $(LDSTATIC) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
40 $(STRIP) $@
41
42 .PHONY: compressed
diff --git a/recipes-support/lshw/lshw_02.16.bb b/recipes-support/lshw/lshw_02.16.bb
index 3a61dab..0b057bd 100644
--- a/recipes-support/lshw/lshw_02.16.bb
+++ b/recipes-support/lshw/lshw_02.16.bb
@@ -17,7 +17,8 @@ COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
17PR="r1" 17PR="r1"
18 18
19SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \ 19SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
20 file://cross-compile.patch" 20 file://cross-compile.patch \
21 file://ldflags.patch"
21 22
22SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d" 23SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d"
23SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb" 24SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb"