summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-09-02 17:55:48 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-09-12 14:58:42 +0200
commitd0d74fbff4709ab9b093ec7785794d7f82b8e7b3 (patch)
tree26b4cc34d9e92178b41d9ed8bb3b728535b81b2a /recipes-support
parent9f816bdb3da9412e334cb8f7a69b48523732dc77 (diff)
downloadmeta-updater-d0d74fbff4709ab9b093ec7785794d7f82b8e7b3.tar.gz
Build OSTree natively, and its dependencies as well
Bug-AGL: SPEC-245 Change-Id: Ia5631d786c3375ba3aa0bc6ac75ebaeb358e7b03 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/fuse/fuse_%.bbappend3
-rw-r--r--recipes-support/glib-networking/glib-networking_%.bbappend1
-rw-r--r--recipes-support/gpgme/gpgme_%.bbappend1
-rw-r--r--recipes-support/libgsystem/libgsystem_git.bb38
-rw-r--r--recipes-support/libsoup/libsoup-2.4_%.bbappend3
-rw-r--r--recipes-support/util-linux/util-linux_%.bbappend10
6 files changed, 56 insertions, 0 deletions
diff --git a/recipes-support/fuse/fuse_%.bbappend b/recipes-support/fuse/fuse_%.bbappend
new file mode 100644
index 0000000..4f23349
--- /dev/null
+++ b/recipes-support/fuse/fuse_%.bbappend
@@ -0,0 +1,3 @@
1BBCLASSEXTEND = "native"
2
3PACKAGES_append_class-native = "fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native"
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend
new file mode 100644
index 0000000..d3267ac
--- /dev/null
+++ b/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -0,0 +1 @@
BBCLASSEXTEND = "native"
diff --git a/recipes-support/gpgme/gpgme_%.bbappend b/recipes-support/gpgme/gpgme_%.bbappend
new file mode 100644
index 0000000..d3267ac
--- /dev/null
+++ b/recipes-support/gpgme/gpgme_%.bbappend
@@ -0,0 +1 @@
BBCLASSEXTEND = "native"
diff --git a/recipes-support/libgsystem/libgsystem_git.bb b/recipes-support/libgsystem/libgsystem_git.bb
new file mode 100644
index 0000000..4b1eb49
--- /dev/null
+++ b/recipes-support/libgsystem/libgsystem_git.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GIO-based library, targeted primarily for use by operating system components"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4
5SRC_URI = "gitsm://github.com/GNOME/libgsystem.git"
6SRCREV="d606bec68ddfea78de4b03c3f3568afb71bdc1ce"
7
8S = "${WORKDIR}/git"
9
10inherit autotools-brokensep
11
12DEPENDS += "attr glib-2.0 pkgconfig libcap"
13RDEPENDS_${PN} = "xz systemd"
14
15RDEPENDS_${PN}_remove_class-native = "systemd-native"
16
17BBCLASSEXTEND = "native"
18
19export STAGING_INCDIR
20export STAGING_LIBDIR
21
22do_configure() {
23 NOCONFIGURE=true ./autogen.sh
24 oe_runconf
25}
26
27do_compile_prepend() {
28 export BUILD_SYS="${BUILD_SYS}"
29 export HOST_SYS="${HOST_SYS}"
30}
31
32FILES_${PN} += " \
33 ${datadir} \
34 ${datadir}/gir-1.0 \
35 ${datadir}/gir-1.0/GSystem-1.0.gir \
36 ${libdir}/girepository-1.0/ \
37 ${libdir}/girepository-1.0/GSystem-1.0.typelib \
38"
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend
new file mode 100644
index 0000000..ed24273
--- /dev/null
+++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -0,0 +1,3 @@
1BBCLASSEXTEND = "native"
2
3DEPENDS_append_class-native = " glib-networking-native"
diff --git a/recipes-support/util-linux/util-linux_%.bbappend b/recipes-support/util-linux/util-linux_%.bbappend
new file mode 100644
index 0000000..bd3f686
--- /dev/null
+++ b/recipes-support/util-linux/util-linux_%.bbappend
@@ -0,0 +1,10 @@
1PACKAGES_append_class-native = "util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native \
2 util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native \
3 util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native \
4 util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid \
5 util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native \
6 util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native \
7 util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock \
8 util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native \
9 ${@bb.utils.contains('PACKAGECONFIG', 'pylibmount', 'util-linux-pylibmount-native', '', d)}"
10