summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-04-27 11:56:14 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2017-05-10 13:46:18 +0200
commit83e834567264d2e38ea6e184a809159e5a13f5a8 (patch)
tree977acf085fd77113d438b6bfb4df0e5216145126 /recipes-support
parentbae52014b6e3a49e7adf49373238dab9f5f3b4a2 (diff)
downloadmeta-updater-83e834567264d2e38ea6e184a809159e5a13f5a8.tar.gz
Make layer inclusion a neutral operation
Classes are and bbappends are reworked so that mere inclusion of this layer to bbappends.conf doesn't change anything. In addition class behavior can now be controlled by both inheriting sota.bblcass and enabling "sota" DISTRO_FEATURE.
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/fuse/fuse_%.bbappend4
-rw-r--r--recipes-support/glib-networking/glib-networking_%.bbappend2
-rw-r--r--recipes-support/gpgme/gpgme_%.bbappend2
-rw-r--r--recipes-support/libsoup/libsoup-2.4_%.bbappend4
-rw-r--r--recipes-support/libssh2/libssh2_%.bbappend2
-rw-r--r--recipes-support/util-linux/util-linux_%.bbappend11
6 files changed, 9 insertions, 16 deletions
diff --git a/recipes-support/fuse/fuse_%.bbappend b/recipes-support/fuse/fuse_%.bbappend
index 4f23349..85bdf50 100644
--- a/recipes-support/fuse/fuse_%.bbappend
+++ b/recipes-support/fuse/fuse_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND = "native" 1BBCLASSEXTEND_append_sota = " native"
2 2
3PACKAGES_append_class-native = "fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native" 3PACKAGES_append_class-native_sota = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' fuse-utils-dbg-native fuse-utils-native libulockmgr-native libulockmgr-dev-native libulockmgr-dbg-native', ' ', d)}"
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend
index d3267ac..fccb949 100644
--- a/recipes-support/glib-networking/glib-networking_%.bbappend
+++ b/recipes-support/glib-networking/glib-networking_%.bbappend
@@ -1 +1 @@
BBCLASSEXTEND = "native" BBCLASSEXTEND_append_sota = " native"
diff --git a/recipes-support/gpgme/gpgme_%.bbappend b/recipes-support/gpgme/gpgme_%.bbappend
index d3267ac..27f258e 100644
--- a/recipes-support/gpgme/gpgme_%.bbappend
+++ b/recipes-support/gpgme/gpgme_%.bbappend
@@ -1 +1 @@
BBCLASSEXTEND = "native" BBCLASSEXTEND_append_sota = "native"
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend
index ed24273..ce4df6d 100644
--- a/recipes-support/libsoup/libsoup-2.4_%.bbappend
+++ b/recipes-support/libsoup/libsoup-2.4_%.bbappend
@@ -1,3 +1,3 @@
1BBCLASSEXTEND = "native" 1BBCLASSEXTEND_append_sota = " native"
2 2
3DEPENDS_append_class-native = " glib-networking-native" 3DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}"
diff --git a/recipes-support/libssh2/libssh2_%.bbappend b/recipes-support/libssh2/libssh2_%.bbappend
index ce4807e..bebaf84 100644
--- a/recipes-support/libssh2/libssh2_%.bbappend
+++ b/recipes-support/libssh2/libssh2_%.bbappend
@@ -1,2 +1,2 @@
1# meta-oe/recipes-support/libssh2 1# meta-oe/recipes-support/libssh2
2BBCLASSEXTEND = "native" 2BBCLASSEXTEND_append_sota = " native"
diff --git a/recipes-support/util-linux/util-linux_%.bbappend b/recipes-support/util-linux/util-linux_%.bbappend
index bd3f686..d653bb2 100644
--- a/recipes-support/util-linux/util-linux_%.bbappend
+++ b/recipes-support/util-linux/util-linux_%.bbappend
@@ -1,10 +1,3 @@
1PACKAGES_append_class-native = "util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native \ 1PACKAGES_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' util-linux-agetty-native util-linux-fdisk-native util-linux-cfdisk-native util-linux-sfdisk-native util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native', ' ', d)}"
2 util-linux-swaponoff-native util-linux-losetup-native util-linux-umount-native \
3 util-linux-mount-native util-linux-readprofile-native util-linux-uuidd-native \
4 util-linux-uuidgen-native util-linux-lscpu-native util-linux-fsck-native util-linux-blkid \
5 util-linux-mkfs-native util-linux-mcookie-native util-linux-reset-native \
6 util-linux-mkfs.cramfs-native util-linux-fsck.cramfs-native util-linux-fstrim-native \
7 util-linux-partx-native ${PN}-bash-completion-native util-linux-hwclock \
8 util-linux-findfs-native util-linux-getopt-native util-linux-sulogin-native \
9 ${@bb.utils.contains('PACKAGECONFIG', 'pylibmount', 'util-linux-pylibmount-native', '', d)}"
10 2
3PACKAGES_append_class-native = "${@' util-linux-pylibmount-native' if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d) and bb.utils.contains('PACKAGECONFIG', 'pylibmount', True, False, d) else ' '}"