summaryrefslogtreecommitdiffstats
path: root/recipes-support
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-03-30 17:48:10 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2017-04-03 12:10:15 +0200
commit501e07acd803df6f9264c4206b4b9529006f287a (patch)
tree20e5bd1f9b3ffd4f230c9c9f5ac87fa85e626617 /recipes-support
parent95b5db5a2714d429d31c42d079b192e8edb1a079 (diff)
downloadmeta-updater-501e07acd803df6f9264c4206b4b9529006f287a.tar.gz
Merge from meta-agl-extra
Diffstat (limited to 'recipes-support')
-rw-r--r--recipes-support/libgit2/libgit2-release.inc2
-rw-r--r--recipes-support/libgit2/libgit2.inc19
-rw-r--r--recipes-support/libgit2/libgit2_0.24.1.bb4
-rw-r--r--recipes-support/lshw/lshw_02.16.bb3
-rw-r--r--recipes-support/python-canonicaljson/python-canonicaljson.bb18
-rw-r--r--recipes-support/python-frozendict/python-frozendict.bb12
6 files changed, 31 insertions, 27 deletions
diff --git a/recipes-support/libgit2/libgit2-release.inc b/recipes-support/libgit2/libgit2-release.inc
deleted file mode 100644
index 62a13cf..0000000
--- a/recipes-support/libgit2/libgit2-release.inc
+++ /dev/null
@@ -1,2 +0,0 @@
1require libgit2.inc
2SRC_URI = "https://github.com/libgit2/libgit2/archive/v${PV}.tar.gz"
diff --git a/recipes-support/libgit2/libgit2.inc b/recipes-support/libgit2/libgit2.inc
deleted file mode 100644
index a0da834..0000000
--- a/recipes-support/libgit2/libgit2.inc
+++ /dev/null
@@ -1,19 +0,0 @@
1SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception"
4
5DEPENDS = "openssl zlib"
6
7inherit cmake
8
9# CLAR = tests, needs python-native
10EXTRA_OECMAKE = "\
11 -DTHREADSAFE=ON \
12 -DBUILD_CLAR=OFF \
13 -DSHA1_TYPE="builtin" \
14 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
15 -DBUILD_SHARED_LIBS=ON \
16 -DBUILD_EXAMPLES=OFF \
17"
18
19BBCLASSEXTEND = "native"
diff --git a/recipes-support/libgit2/libgit2_0.24.1.bb b/recipes-support/libgit2/libgit2_0.24.1.bb
deleted file mode 100644
index 2d0c6ff..0000000
--- a/recipes-support/libgit2/libgit2_0.24.1.bb
+++ /dev/null
@@ -1,4 +0,0 @@
1LIC_FILES_CHKSUM = "file://COPYING;md5=34197a479f637beb9e09e56893f48bc2"
2SRC_URI[md5sum] = "3674ca2d40388b1175e25b6f5a3a82ad"
3SRC_URI[sha256sum] = "60198cbb34066b9b5c1613d15c0479f6cd25f4aef42f7ec515cd1cc13a77fede"
4require libgit2-release.inc
diff --git a/recipes-support/lshw/lshw_02.16.bb b/recipes-support/lshw/lshw_02.16.bb
index 53b0d65..99901ff 100644
--- a/recipes-support/lshw/lshw_02.16.bb
+++ b/recipes-support/lshw/lshw_02.16.bb
@@ -14,12 +14,11 @@ DEPENDS = "pciutils \
14 usbutils" 14 usbutils"
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" 15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16 16
17PR="r1"
18
19SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \ 17SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
20 file://cross-compile.patch \ 18 file://cross-compile.patch \
21 file://ldflags.patch \ 19 file://ldflags.patch \
22 " 20 "
21
23SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d" 22SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d"
24SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb" 23SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb"
25 24
diff --git a/recipes-support/python-canonicaljson/python-canonicaljson.bb b/recipes-support/python-canonicaljson/python-canonicaljson.bb
new file mode 100644
index 0000000..d8a0728
--- /dev/null
+++ b/recipes-support/python-canonicaljson/python-canonicaljson.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "python-canonicaljson recipe"
2
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
5
6SRCREV = "92e2c06871cc275c2a8b8e3e899141a212aae0e8"
7SRC_URI = "git://github.com/matrix-org/python-canonicaljson.git"
8S = "${WORKDIR}/git"
9
10# Generate with:
11# git describe --tags | cut -b2-
12PV = "1.0.0"
13inherit setuptools
14
15RDEPENDS_${PN} = "\
16 python-simplejson \
17 python-frozendict \
18 "
diff --git a/recipes-support/python-frozendict/python-frozendict.bb b/recipes-support/python-frozendict/python-frozendict.bb
new file mode 100644
index 0000000..79fe5c8
--- /dev/null
+++ b/recipes-support/python-frozendict/python-frozendict.bb
@@ -0,0 +1,12 @@
1DESCRIPTION = "python-frozendict recipe"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://${S}/LICENSE.txt;md5=f4da037a49c09b456fdbbc7a5bd36132"
5
6SRCREV = "c5d16bafcca7b72ff3e8f40d3a9081e4c9233f1b"
7SRC_URI = "git://github.com/slezica/python-frozendict.git"
8S = "${WORKDIR}/git"
9
10PV = "1.2"
11inherit setuptools
12