diff options
author | Ricardo Salveti <ricardo@foundries.io> | 2019-01-17 11:58:12 -0200 |
---|---|---|
committer | Ricardo Salveti <ricardo@foundries.io> | 2019-01-17 12:42:11 -0200 |
commit | 5ac462299def05b7a49be25a0076c611482cb9c9 (patch) | |
tree | cba1d9563ec4941e5859e467b57eec5ba9c84bf1 /recipes-support | |
parent | 90402a607676cc56d718f1c84294f05ee571f416 (diff) | |
download | meta-updater-5ac462299def05b7a49be25a0076c611482cb9c9.tar.gz |
libp11: bump to git 57ca68f for EC signing support
libp11 0.4.9 gives an error when EC keys are used for signing
(pkcs11_try_pkey_ec_sign() not implemented), so bump to git 57ca68f
(post 0.4.9) for EC signing support.
Also drop workaround patch for OpenSSL 1.0.2.m since OE OpenSSL version
is now at 1.1.1a.
Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
Diffstat (limited to 'recipes-support')
-rw-r--r-- | recipes-support/libp11/files/0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch | 42 | ||||
-rw-r--r-- | recipes-support/libp11/libp11_git.bb (renamed from recipes-support/libp11/libp11_0.4.9.bb) | 7 |
2 files changed, 4 insertions, 45 deletions
diff --git a/recipes-support/libp11/files/0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch b/recipes-support/libp11/files/0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch deleted file mode 100644 index 55f2ed3..0000000 --- a/recipes-support/libp11/files/0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | From ccab5ce63dd5d3dbb4bd02998d21d34407e550f2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Anton Gerasimov <anton.gerasimov@here.com> | ||
3 | Date: Fri, 19 Jan 2018 12:44:27 +0100 | ||
4 | Subject: [PATCH] Workaround for a buggy version of openssl (1.0.2m) | ||
5 | |||
6 | --- | ||
7 | src/p11_pkey.c | 12 +++++++++--- | ||
8 | 1 file changed, 9 insertions(+), 3 deletions(-) | ||
9 | |||
10 | diff --git a/src/p11_pkey.c b/src/p11_pkey.c | ||
11 | index 45d5ad3..75625e6 100644 | ||
12 | --- a/src/p11_pkey.c | ||
13 | +++ b/src/p11_pkey.c | ||
14 | @@ -139,8 +139,14 @@ static void EVP_PKEY_meth_copy(EVP_PKEY_METHOD *dst, const EVP_PKEY_METHOD *src) | ||
15 | |||
16 | #endif | ||
17 | |||
18 | -#if OPENSSL_VERSION_NUMBER < 0x100020d0L || defined(LIBRESSL_VERSION_NUMBER) | ||
19 | -static void EVP_PKEY_meth_get_sign(EVP_PKEY_METHOD *pmeth, | ||
20 | +#if OPENSSL_VERSION_NUMBER < 0x10002110L || defined(LIBRESSL_VERSION_NUMBER) | ||
21 | + | ||
22 | +# if (OPENSSL_VERSION_NUMBER & 0xFFFFFFF0) == 0x100020d0L | ||
23 | +# undef EVP_PKEY_meth_get_sign | ||
24 | +# undef EVP_PKEY_meth_get_decrypt | ||
25 | +# endif | ||
26 | + | ||
27 | +void EVP_PKEY_meth_get_sign(EVP_PKEY_METHOD *pmeth, | ||
28 | int (**psign_init) (EVP_PKEY_CTX *ctx), | ||
29 | int (**psign) (EVP_PKEY_CTX *ctx, | ||
30 | unsigned char *sig, size_t *siglen, | ||
31 | @@ -152,7 +158,7 @@ static void EVP_PKEY_meth_get_sign(EVP_PKEY_METHOD *pmeth, | ||
32 | *psign = pmeth->sign; | ||
33 | } | ||
34 | |||
35 | -static void EVP_PKEY_meth_get_decrypt(EVP_PKEY_METHOD *pmeth, | ||
36 | +void EVP_PKEY_meth_get_decrypt(EVP_PKEY_METHOD *pmeth, | ||
37 | int (**pdecrypt_init) (EVP_PKEY_CTX *ctx), | ||
38 | int (**pdecrypt) (EVP_PKEY_CTX *ctx, | ||
39 | unsigned char *out, | ||
40 | -- | ||
41 | 2.15.1 | ||
42 | |||
diff --git a/recipes-support/libp11/libp11_0.4.9.bb b/recipes-support/libp11/libp11_git.bb index 6d0165f..bedcdc8 100644 --- a/recipes-support/libp11/libp11_0.4.9.bb +++ b/recipes-support/libp11/libp11_git.bb | |||
@@ -9,9 +9,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29" | |||
9 | DEPENDS = "libtool openssl" | 9 | DEPENDS = "libtool openssl" |
10 | RDEPENDS_${PN} += " opensc" | 10 | RDEPENDS_${PN} += " opensc" |
11 | 11 | ||
12 | SRC_URI = "git://github.com/OpenSC/libp11.git \ | 12 | SRC_URI = "git://github.com/OpenSC/libp11.git" |
13 | file://0001-Workaround-for-a-buggy-version-of-openssl-1.0.2m.patch" | 13 | SRCREV = "57ca68ff67efa08e3be1f26dec6d23bf5bb977f2" |
14 | SRCREV = "e1210903291b1de9eabcad26e740a4b2fbcca692" | 14 | |
15 | PV = "0.4.9+git${SRCPV}" | ||
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
17 | 18 | ||