diff options
author | Anton Gerasimov <anton@advancedtelematic.com> | 2016-10-28 14:08:40 +0200 |
---|---|---|
committer | Anton Gerasimov <anton@advancedtelematic.com> | 2016-10-31 18:21:26 +0100 |
commit | e42ce3ea63bcf488c743654e983ea018664dda06 (patch) | |
tree | 090c4ebd999a10332d8213cbdf7cd532d1522e40 /recipes-support | |
parent | 0939263a7c543e4d2bd667245ce257c2a6d6b9af (diff) | |
download | meta-updater-e42ce3ea63bcf488c743654e983ea018664dda06.tar.gz |
Update rvi-sota-client
Change-Id: I1d5ceb776427298d46ab26dab2c822041dff00e0
Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'recipes-support')
-rw-r--r-- | recipes-support/libgit2/libgit2-release.inc | 2 | ||||
-rw-r--r-- | recipes-support/libgit2/libgit2.inc | 19 | ||||
-rw-r--r-- | recipes-support/libgit2/libgit2_0.24.1.bb | 4 | ||||
-rw-r--r-- | recipes-support/libssh2/libssh2_%.bbappend | 2 | ||||
-rw-r--r-- | recipes-support/lshw/files/cross-compile.patch | 39 | ||||
-rw-r--r-- | recipes-support/lshw/lshw_02.16.bb | 36 |
6 files changed, 102 insertions, 0 deletions
diff --git a/recipes-support/libgit2/libgit2-release.inc b/recipes-support/libgit2/libgit2-release.inc new file mode 100644 index 0000000..62a13cf --- /dev/null +++ b/recipes-support/libgit2/libgit2-release.inc | |||
@@ -0,0 +1,2 @@ | |||
1 | require libgit2.inc | ||
2 | SRC_URI = "https://github.com/libgit2/libgit2/archive/v${PV}.tar.gz" | ||
diff --git a/recipes-support/libgit2/libgit2.inc b/recipes-support/libgit2/libgit2.inc new file mode 100644 index 0000000..fe0f647 --- /dev/null +++ b/recipes-support/libgit2/libgit2.inc | |||
@@ -0,0 +1,19 @@ | |||
1 | SUMMARY = "the Git linkable library" | ||
2 | HOMEPAGE = "http://libgit2.github.com/" | ||
3 | LICENSE = "GPL-2.0-with-GCC-exception" | ||
4 | |||
5 | DEPENDS = "openssl zlib" | ||
6 | |||
7 | inherit cmake | ||
8 | |||
9 | # CLAR = tests, needs python-native | ||
10 | EXTRA_OECMAKE = "\ | ||
11 | -DTHREADSAFE=ON \ | ||
12 | -DBUILD_CLAR=OFF \ | ||
13 | -DSHA1_TYPE="builtin" \ | ||
14 | -DCMAKE_BUILD_TYPE=RelWithDebInfo \ | ||
15 | -DBUILD_SHARED_LIBS=OFF \ | ||
16 | -DBUILD_EXAMPLES=OFF \ | ||
17 | " | ||
18 | |||
19 | BBCLASSEXTEND = "native" | ||
diff --git a/recipes-support/libgit2/libgit2_0.24.1.bb b/recipes-support/libgit2/libgit2_0.24.1.bb new file mode 100644 index 0000000..2d0c6ff --- /dev/null +++ b/recipes-support/libgit2/libgit2_0.24.1.bb | |||
@@ -0,0 +1,4 @@ | |||
1 | LIC_FILES_CHKSUM = "file://COPYING;md5=34197a479f637beb9e09e56893f48bc2" | ||
2 | SRC_URI[md5sum] = "3674ca2d40388b1175e25b6f5a3a82ad" | ||
3 | SRC_URI[sha256sum] = "60198cbb34066b9b5c1613d15c0479f6cd25f4aef42f7ec515cd1cc13a77fede" | ||
4 | require libgit2-release.inc | ||
diff --git a/recipes-support/libssh2/libssh2_%.bbappend b/recipes-support/libssh2/libssh2_%.bbappend new file mode 100644 index 0000000..ce4807e --- /dev/null +++ b/recipes-support/libssh2/libssh2_%.bbappend | |||
@@ -0,0 +1,2 @@ | |||
1 | # meta-oe/recipes-support/libssh2 | ||
2 | BBCLASSEXTEND = "native" | ||
diff --git a/recipes-support/lshw/files/cross-compile.patch b/recipes-support/lshw/files/cross-compile.patch new file mode 100644 index 0000000..221b7e5 --- /dev/null +++ b/recipes-support/lshw/files/cross-compile.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | --- | ||
2 | src/Makefile | 2 +- | ||
3 | src/core/Makefile | 2 +- | ||
4 | src/gui/Makefile | 4 ++-- | ||
5 | 3 files changed, 4 insertions(+), 4 deletions(-) | ||
6 | |||
7 | --- a/src/Makefile | ||
8 | +++ b/src/Makefile | ||
9 | @@ -18,7 +18,7 @@ export MANDIR | ||
10 | export DATADIR | ||
11 | export SQLITE | ||
12 | |||
13 | -CXX?=c++ | ||
14 | +CXX?=$(CROSS_COMPILE)c++ | ||
15 | INCLUDES=-I./core/ | ||
16 | DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\" | ||
17 | CXXFLAGS=-g -Wall -g $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS) | ||
18 | --- a/src/core/Makefile | ||
19 | +++ b/src/core/Makefile | ||
20 | @@ -1,6 +1,6 @@ | ||
21 | PACKAGENAME?=lshw | ||
22 | |||
23 | -CXX=c++ | ||
24 | +CXX?=$(CROSS_COMPILE)c++ | ||
25 | INCLUDES= | ||
26 | DEFINES=-DPREFIX=\"$(PREFIX)\" -DSBINDIR=\"$(SBINDIR)\" -DMANDIR=\"$(MANDIR)\" -DDATADIR=\"$(DATADIR)\" | ||
27 | CXXFLAGS?=-g -Wall $(INCLUDES) $(DEFINES) $(RPM_OPT_FLAGS) | ||
28 | --- a/src/gui/Makefile | ||
29 | +++ b/src/gui/Makefile | ||
30 | @@ -1,7 +1,7 @@ | ||
31 | PACKAGENAME?=lshw | ||
32 | |||
33 | -CXX?=c++ | ||
34 | -CC?=cc | ||
35 | +CXX?=$(CROSS_COMPILE)c++ | ||
36 | +CC?=$(CROSS_COMPILE)cc | ||
37 | STRIP?=strip | ||
38 | OBJCOPY?=objcopy | ||
39 | |||
diff --git a/recipes-support/lshw/lshw_02.16.bb b/recipes-support/lshw/lshw_02.16.bb new file mode 100644 index 0000000..3a61dab --- /dev/null +++ b/recipes-support/lshw/lshw_02.16.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | # From meta-linaro | ||
2 | # http://git.linaro.org/openembedded/meta-linaro.git | ||
3 | |||
4 | DESCRIPTION = "A small tool to provide detailed information on the hardware \ | ||
5 | configuration of the machine. It can report exact memory configuration, \ | ||
6 | firmware version, mainboard configuration, CPU version and speed, cache \ | ||
7 | configuration, bus speed, etc. on DMI-capable or EFI systems." | ||
8 | SUMMARY = "Hardware lister" | ||
9 | HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter" | ||
10 | SECTION = "console/tools" | ||
11 | LICENSE = "GPLv2+" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | ||
13 | DEPENDS = "pciutils \ | ||
14 | usbutils" | ||
15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | ||
16 | |||
17 | PR="r1" | ||
18 | |||
19 | SRC_URI="http://ezix.org/software/files/lshw-B.${PV}.tar.gz \ | ||
20 | file://cross-compile.patch" | ||
21 | |||
22 | SRC_URI[md5sum] = "67479167add605e8f001097c30e96d0d" | ||
23 | SRC_URI[sha256sum] = "809882429555b93259785cc261dbff04c16c93d064db5f445a51945bc47157cb" | ||
24 | |||
25 | S="${WORKDIR}/lshw-B.${PV}" | ||
26 | |||
27 | do_compile() { | ||
28 | # build core only - don't ship gui | ||
29 | oe_runmake -C src core | ||
30 | } | ||
31 | |||
32 | do_install() { | ||
33 | oe_runmake install DESTDIR=${D} | ||
34 | # data files provided by dependencies | ||
35 | rm -rf ${D}/usr/share/lshw | ||
36 | } | ||