diff options
author | Anton Gerasimov <anton@advancedtelematic.com> | 2017-12-22 19:14:16 +0100 |
---|---|---|
committer | Anton Gerasimov <anton.gerasimov@openmailbox.org> | 2018-01-08 15:18:13 +0100 |
commit | 537de14d5018f9525964e7d4c64d736e9186c696 (patch) | |
tree | dde83617d1e109a978296f6a3ad508b26b5b4f65 /recipes-support | |
parent | 2f5b892d318f9b22747aed4618d3f15728de9980 (diff) | |
download | meta-updater-537de14d5018f9525964e7d4c64d736e9186c696.tar.gz |
Add support of ISO/TP legacy secondaries and serial CAN
Diffstat (limited to 'recipes-support')
-rw-r--r-- | recipes-support/slcand-start/files/slcand@.service | 8 | ||||
-rw-r--r-- | recipes-support/slcand-start/slcand-start.bb | 21 |
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-support/slcand-start/files/slcand@.service b/recipes-support/slcand-start/files/slcand@.service new file mode 100644 index 0000000..c539568 --- /dev/null +++ b/recipes-support/slcand-start/files/slcand@.service | |||
@@ -0,0 +1,8 @@ | |||
1 | [Unit] | ||
2 | Description=Serial CAN daemon (can-utils) | ||
3 | |||
4 | [Service] | ||
5 | Type=forking | ||
6 | ExecStart=/usr/bin/slcand -o -c -s4 %I can0 | ||
7 | ExecStartPost=/bin/sh -c '/bin/sleep 3; /sbin/ip link set can0 up' | ||
8 | |||
diff --git a/recipes-support/slcand-start/slcand-start.bb b/recipes-support/slcand-start/slcand-start.bb new file mode 100644 index 0000000..dfefaea --- /dev/null +++ b/recipes-support/slcand-start/slcand-start.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Mock smartcard for aktualizr" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ | ||
4 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
5 | |||
6 | |||
7 | inherit systemd | ||
8 | |||
9 | RDEPENDS_${PN} = "can-utils" | ||
10 | |||
11 | SRC_URI = "file://slcand@.service" | ||
12 | |||
13 | SYSTEMD_SERVICE_${PN} = "slcand@.service" | ||
14 | |||
15 | do_install() { | ||
16 | install -d ${D}${systemd_unitdir}/system | ||
17 | install -m 0644 ${WORKDIR}/slcand@.service ${D}${systemd_unitdir}/system/slcand@.service | ||
18 | } | ||
19 | |||
20 | FILES_${PN} = "${systemd_unitdir}/system/createtoken.service" | ||
21 | |||