diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2018-01-17 10:22:50 +0100 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2018-01-17 10:22:50 +0100 |
commit | e5228ae1d05280f2810c90bef16a9046960aa9ca (patch) | |
tree | 4301167ac818124a7d38e11aeb362b8345a812c8 /recipes-support | |
parent | 623c51d713f359210874dd50c1394bcc901228ec (diff) | |
parent | 0afff0c944763238026283fbb409d038705c6b13 (diff) | |
download | meta-updater-e5228ae1d05280f2810c90bef16a9046960aa9ca.tar.gz |
Merge branch 'pyro' into bugfix/update-rocko
Bring over fixes from the last couple months from pyro in rocko.
Diffstat (limited to 'recipes-support')
5 files changed, 30 insertions, 12 deletions
diff --git a/recipes-support/ca-certificates/ca-certificates_%.bbappend b/recipes-support/ca-certificates/ca-certificates_%.bbappend index afaadfd..cc95a68 100644 --- a/recipes-support/ca-certificates/ca-certificates_%.bbappend +++ b/recipes-support/ca-certificates/ca-certificates_%.bbappend | |||
@@ -1 +1 @@ | |||
SYSROOT_DIRS += "/etc" | SYSROOT_DIRS += "${sysconfdir}" | ||
diff --git a/recipes-support/glib-networking/glib-networking_%.bbappend b/recipes-support/glib-networking/glib-networking_%.bbappend deleted file mode 100644 index 22e6f05..0000000 --- a/recipes-support/glib-networking/glib-networking_%.bbappend +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | BBCLASSEXTEND_append_sota = " native nativesdk" | ||
2 | |||
3 | # Hackery to prevent relocatable_native_pcfiles from crashing | ||
4 | do_install_append_class-native () { | ||
5 | if [ -d ${D}${libdir}/pkgconfig ]; then | ||
6 | rmdir ${D}${libdir}/pkgconfig | ||
7 | fi | ||
8 | } | ||
diff --git a/recipes-support/libsoup/libsoup-2.4_%.bbappend b/recipes-support/libsoup/libsoup-2.4_%.bbappend deleted file mode 100644 index 18383f1..0000000 --- a/recipes-support/libsoup/libsoup-2.4_%.bbappend +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | BBCLASSEXTEND_append_sota = " native nativesdk" | ||
2 | |||
3 | DEPENDS_append_class-native = "${@bb.utils.contains('DISTRO_FEATURES', 'sota', ' glib-networking-native', ' ', d)}" | ||
diff --git a/recipes-support/slcand-start/files/slcand@.service b/recipes-support/slcand-start/files/slcand@.service new file mode 100644 index 0000000..c539568 --- /dev/null +++ b/recipes-support/slcand-start/files/slcand@.service | |||
@@ -0,0 +1,8 @@ | |||
1 | [Unit] | ||
2 | Description=Serial CAN daemon (can-utils) | ||
3 | |||
4 | [Service] | ||
5 | Type=forking | ||
6 | ExecStart=/usr/bin/slcand -o -c -s4 %I can0 | ||
7 | ExecStartPost=/bin/sh -c '/bin/sleep 3; /sbin/ip link set can0 up' | ||
8 | |||
diff --git a/recipes-support/slcand-start/slcand-start.bb b/recipes-support/slcand-start/slcand-start.bb new file mode 100644 index 0000000..dfefaea --- /dev/null +++ b/recipes-support/slcand-start/slcand-start.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Mock smartcard for aktualizr" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ | ||
4 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
5 | |||
6 | |||
7 | inherit systemd | ||
8 | |||
9 | RDEPENDS_${PN} = "can-utils" | ||
10 | |||
11 | SRC_URI = "file://slcand@.service" | ||
12 | |||
13 | SYSTEMD_SERVICE_${PN} = "slcand@.service" | ||
14 | |||
15 | do_install() { | ||
16 | install -d ${D}${systemd_unitdir}/system | ||
17 | install -m 0644 ${WORKDIR}/slcand@.service ${D}${systemd_unitdir}/system/slcand@.service | ||
18 | } | ||
19 | |||
20 | FILES_${PN} = "${systemd_unitdir}/system/createtoken.service" | ||
21 | |||