summaryrefslogtreecommitdiffstats
path: root/recipes-support/softhsm/softhsm_git.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2017-09-08 17:11:33 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2017-09-13 11:53:33 +0200
commit4a7366c4f161a98611a292394a9662a0c507f904 (patch)
tree2b71f99717dec2b17c23684bc20311c926489d32 /recipes-support/softhsm/softhsm_git.bb
parent6db91a2e484ab026dd50817147beed31c49abc2b (diff)
downloadmeta-updater-4a7366c4f161a98611a292394a9662a0c507f904.tar.gz
Add recipes to test pkcs11 functionality in Aktualizr
Diffstat (limited to 'recipes-support/softhsm/softhsm_git.bb')
-rw-r--r--recipes-support/softhsm/softhsm_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-support/softhsm/softhsm_git.bb b/recipes-support/softhsm/softhsm_git.bb
new file mode 100644
index 0000000..c26903d
--- /dev/null
+++ b/recipes-support/softhsm/softhsm_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "HSM emulator"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
4
5inherit autotools-brokensep
6
7
8SRC_URI = "git://github.com/opendnssec/SoftHSMv2.git;branch=master \
9 file://0001-Cross-compilation-tweaks.patch"
10SRCREV="1f7498c0c65b1b1ad5e1bdbd87e9d4b100705745"
11
12S = "${WORKDIR}/git"
13
14DEPENDS += " openssl"
15
16EXTRA_OECONF = "--disable-gost --with-openssl=${STAGING_LIBDIR}/.."
17
18do_configure() {
19 unset docdir
20 sh ./autogen.sh
21 oe_runconf
22}
23
24FILES_${PN} = "${bindir} \
25 ${libdir}/softhsm \
26 ${sysconfdir} \
27 ${localstatedir}/lib/softhsm "