summaryrefslogtreecommitdiffstats
path: root/recipes-support/lshw/files/ldflags.patch
diff options
context:
space:
mode:
authorAnatoliy Odukha <aodukha@gmail.com>2020-11-02 18:03:24 +0200
committerGitHub <noreply@github.com>2020-11-02 18:03:24 +0200
commit7066c9d14dfb63cad7f6df70da8c3a2d1939ce5c (patch)
treef6c9d9c14893b4f7680ffc7677bad31d74383e68 /recipes-support/lshw/files/ldflags.patch
parent364c327ecf919641baea335e7fe8a500c78d1e40 (diff)
parent0864efdf80dcd25bb31b0030cac621a88654fc95 (diff)
downloadmeta-updater-7066c9d14dfb63cad7f6df70da8c3a2d1939ce5c.tar.gz
Merge pull request #783 from advancedtelematic/feat/zeus/2020.10
aktualizr: Upgrade zeus to 2020.10 release
Diffstat (limited to 'recipes-support/lshw/files/ldflags.patch')
-rw-r--r--recipes-support/lshw/files/ldflags.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/recipes-support/lshw/files/ldflags.patch b/recipes-support/lshw/files/ldflags.patch
deleted file mode 100644
index d95699d..0000000
--- a/recipes-support/lshw/files/ldflags.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1diff -Naur /home/anton/lshw-old/src/Makefile lshw-B.02.17/src/Makefile
2--- /home/anton/lshw-old/src/Makefile 2017-02-07 16:21:52.554738182 +0100
3+++ lshw-B.02.17/src/Makefile 2017-02-07 16:22:45.578588072 +0100
4@@ -25,9 +25,9 @@
5 ifeq ($(SQLITE), 1)
6 CXXFLAGS+= -DSQLITE $(shell pkg-config --cflags sqlite3)
7 endif
8-LDFLAGS=-L./core/ -g
9+LDEXTRAS=-L./core/ -g
10 ifneq ($(shell $(LD) --help 2| grep -- --as-needed), )
11- LDFLAGS+= -Wl,--as-needed
12+ LDEXTRAS+= -Wl,--as-needed
13 endif
14 LDSTATIC=-static
15 LIBS=-llshw -lresolv
16@@ -37,7 +37,7 @@
17
18 export CXXFLAGS
19 export LIBS
20-export LDFLAGS
21+export LDEXTRAS
22
23 DATAFILES = pci.ids usb.ids oui.txt manuf.txt
24
25@@ -51,7 +51,7 @@
26 +make -C core all
27
28 $(PACKAGENAME): core $(PACKAGENAME).o
29- $(CXX) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
30+ $(CXX) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
31
32 .PHONY: po
33 po:
34@@ -69,7 +69,7 @@
35 static: $(PACKAGENAME)-static
36
37 $(PACKAGENAME)-static: core core/lib$(PACKAGENAME).a $(PACKAGENAME).o
38- $(CXX) $(LDSTATIC) $(LDFLAGS) -o $@ $(PACKAGENAME).o $(LIBS)
39+ $(CXX) $(LDSTATIC) $(LDFLAGS) ${LDEXTRAS} -o $@ $(PACKAGENAME).o $(LIBS)
40 $(STRIP) $@
41
42 .PHONY: compressed