summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-08 19:22:58 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2016-11-08 19:22:58 +0000
commit72df99753d8c944d706a6f863b446476a689f348 (patch)
tree00eef801bde87ffd4b3d117e69b0f156a5402a24 /recipes-sota
parentac0c7875ed38e84bb64140675b06e998c356cf3b (diff)
parent937f38696039d236f813340115efac14e189672f (diff)
downloadmeta-updater-72df99753d8c944d706a6f863b446476a689f348.tar.gz
Merge "A tool for uploading OSTree objects to a server together with integration code"
Diffstat (limited to 'recipes-sota')
-rw-r--r--recipes-sota/sota-tools/sota-tools_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-sota/sota-tools/sota-tools_git.bb b/recipes-sota/sota-tools/sota-tools_git.bb
new file mode 100644
index 0000000..acd8e4a
--- /dev/null
+++ b/recipes-sota/sota-tools/sota-tools_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Utility to push data to a server"
2LICENSE = "MPL-2.0"
3
4LIC_FILES_CHKSUM = "file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
5
6S = "${WORKDIR}/git"
7
8SRC_URI = "gitsm://github.com/advancedtelematic/sota-tools.git;branch=master"
9SRCREV = "7ff1d92c161ba4fb047a1e1e4cba5424b4adca00"
10
11inherit cmake
12
13DEPENDS = "boost"
14
15BBCLASSEXTEND = "native"
16
17FILES_${PN} = "${bindir}/garage-push"
18
19EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF"
20
21do_install() {
22 install -d ${D}/${bindir}
23 install -m 755 garage-push ${D}/${bindir}
24}