summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
authorAnton Gerasimov <tossel@gmail.com>2019-02-06 13:13:21 +0100
committerGitHub <noreply@github.com>2019-02-06 13:13:21 +0100
commit3cb25f38e89d969c7894478014e221ba43b49890 (patch)
tree73d80a61f77a11da0e0ded192090c6b2ca3f9209 /recipes-sota
parentbf827e6261caa7e78a98e7448daa2afb3e8d4001 (diff)
parent495f5db09da6a1e5b7a16460d9f4bf26fbee2dff (diff)
downloadmeta-updater-3cb25f38e89d969c7894478014e221ba43b49890.tar.gz
Merge pull request #474 from advancedtelematic/feat/fit-dtbo
Add support for device tree overlays in FIT images
Diffstat (limited to 'recipes-sota')
-rw-r--r--recipes-sota/fit-conf/fit-conf.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-sota/fit-conf/fit-conf.bb b/recipes-sota/fit-conf/fit-conf.bb
new file mode 100644
index 0000000..c6cecec
--- /dev/null
+++ b/recipes-sota/fit-conf/fit-conf.bb
@@ -0,0 +1,22 @@
1SUMMARY = "FIT image configuration for u-boot to use"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5do_install() {
6 mkdir -p ${D}${libdir}
7 echo -n "fit_conf=" >${D}${libdir}/fit_conf
8
9 if [ -n ${SOTA_MAIN_DTB} ]; then
10 echo -n "#conf@${SOTA_MAIN_DTB}" >> ${D}${libdir}/fit_conf
11 fi
12
13 for ovrl in ${SOTA_DT_OVERLAYS}; do
14 echo -n "#conf@overlays_${ovrl}" >> ${D}${libdir}/fit_conf
15 done
16
17 for conf_frag in ${SOTA_EXTRA_CONF_FRAGS}; do
18 echo -n "#${conf_frag}" >> ${D}${libdir}/fit_conf
19 done
20}
21
22FILES_${PN} += "${libdir}/fit_conf"