summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-11-08 11:23:19 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2016-11-08 18:43:07 +0100
commit937f38696039d236f813340115efac14e189672f (patch)
tree43443ed9517a35151b9794fe8101a506d780b44a /recipes-sota
parent34dc600256134efd8013e614105b0f4ca74c8e37 (diff)
downloadmeta-updater-937f38696039d236f813340115efac14e189672f.tar.gz
A tool for uploading OSTree objects to a server together with
integration code Bug-AGL: SPEC-194 Change-Id: I650e190bbda67ad48233bc5aedc0c10ff14aa58f Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'recipes-sota')
-rw-r--r--recipes-sota/sota-tools/sota-tools_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-sota/sota-tools/sota-tools_git.bb b/recipes-sota/sota-tools/sota-tools_git.bb
new file mode 100644
index 0000000..acd8e4a
--- /dev/null
+++ b/recipes-sota/sota-tools/sota-tools_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Utility to push data to a server"
2LICENSE = "MPL-2.0"
3
4LIC_FILES_CHKSUM = "file://LICENSE;md5=65d26fcc2f35ea6a181ac777e42db1ea"
5
6S = "${WORKDIR}/git"
7
8SRC_URI = "gitsm://github.com/advancedtelematic/sota-tools.git;branch=master"
9SRCREV = "7ff1d92c161ba4fb047a1e1e4cba5424b4adca00"
10
11inherit cmake
12
13DEPENDS = "boost"
14
15BBCLASSEXTEND = "native"
16
17FILES_${PN} = "${bindir}/garage-push"
18
19EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF"
20
21do_install() {
22 install -d ${D}/${bindir}
23 install -m 755 garage-push ${D}/${bindir}
24}