diff options
author | Laurent Bonnans <laurent.bonnans@here.com> | 2019-03-11 18:14:49 +0100 |
---|---|---|
committer | Laurent Bonnans <laurent.bonnans@here.com> | 2019-03-11 18:14:49 +0100 |
commit | 010a75a7eebfa3f5d6a7a3fb357ff23634ac3e9e (patch) | |
tree | a64832f2f5c557d35124c783692f7d8f47b4bdfb /recipes-sota | |
parent | dedcbd8c92fa0ba46f76bbb67829aec763317c3f (diff) | |
download | meta-updater-010a75a7eebfa3f5d6a7a3fb357ff23634ac3e9e.tar.gz |
Use 'printf' instead of 'echo -e'fix/bad-echo
Should be less surprising
Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com>
Diffstat (limited to 'recipes-sota')
-rwxr-xr-x | recipes-sota/aktualizr/aktualizr_git.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 2c27935..97f784f 100755 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -69,14 +69,14 @@ do_install_append () { | |||
69 | install -m 0700 -d ${D}${sysconfdir}/sota/conf.d | 69 | install -m 0700 -d ${D}${sysconfdir}/sota/conf.d |
70 | 70 | ||
71 | if [ -n "${SOTA_HARDWARE_ID}" ]; then | 71 | if [ -n "${SOTA_HARDWARE_ID}" ]; then |
72 | echo -e "[provision]\nprimary_ecu_hardware_id = ${SOTA_HARDWARE_ID}\n" > ${D}${libdir}/sota/conf.d/40-hardware-id.toml | 72 | printf "[provision]\nprimary_ecu_hardware_id = ${SOTA_HARDWARE_ID}\n" > ${D}${libdir}/sota/conf.d/40-hardware-id.toml |
73 | fi | 73 | fi |
74 | 74 | ||
75 | if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then | 75 | if [ -n "${SOTA_SECONDARY_CONFIG_DIR}" ]; then |
76 | if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then | 76 | if [ -d "${SOTA_SECONDARY_CONFIG_DIR}" ]; then |
77 | install -m 0700 -d ${D}${sysconfdir}/sota/ecus | 77 | install -m 0700 -d ${D}${sysconfdir}/sota/ecus |
78 | install -m 0644 "${SOTA_SECONDARY_CONFIG_DIR}"/* ${D}${sysconfdir}/sota/ecus/ | 78 | install -m 0644 "${SOTA_SECONDARY_CONFIG_DIR}"/* ${D}${sysconfdir}/sota/ecus/ |
79 | echo -e "[uptane]\nsecondary_configs_dir = /etc/sota/ecus/\n" > ${D}${libdir}/sota/conf.d/30-secondary-configs-dir.toml | 79 | printf "[uptane]\nsecondary_configs_dir = /etc/sota/ecus/\n" > ${D}${libdir}/sota/conf.d/30-secondary-configs-dir.toml |
80 | else | 80 | else |
81 | bbwarn "SOTA_SECONDARY_CONFIG_DIR is set to an invalid directory (${SOTA_SECONDARY_CONFIG_DIR})" | 81 | bbwarn "SOTA_SECONDARY_CONFIG_DIR is set to an invalid directory (${SOTA_SECONDARY_CONFIG_DIR})" |
82 | fi | 82 | fi |