summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
authorAuthor Leon Anavi <leon.anavi@konsulko.com>2017-01-16 14:05:57 +0200
committerPhil Wise <phil@advancedtelematic.com>2017-01-24 09:39:39 +0100
commit1fa2f8ea1c14a4493482ffd692fb3fa39844d827 (patch)
tree2f52101534257d24062100bd302067ffa7c60b70 /recipes-sota
parent98c09deaf442f878dab47951e5a9b39209445b3f (diff)
downloadmeta-updater-1fa2f8ea1c14a4493482ffd692fb3fa39844d827.tar.gz
sota-client-cpp: GENIVI SOTA project in C++
Add Yocto/OE recipe for building GENIVI SOTA project written in C++ with Boost C++ libraries. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'recipes-sota')
-rw-r--r--recipes-sota/sota-client-cpp/sota-client-cpp_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb b/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb
new file mode 100644
index 0000000..b3c841c
--- /dev/null
+++ b/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "SOTA Client"
2DESCRIPTION = "SOTA Client application written in C++"
3HOMEPAGE = "https://github.com/advancedtelematic/sota_client_cpp"
4SECTION = "base"
5
6LICENSE = "MPL-2.0"
7LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3"
8
9inherit cmake systemd
10
11S = "${WORKDIR}/git"
12
13SRCREV = "7194ec4aa39f71157af66751098340c854537817"
14
15SRC_URI = " \
16 git://github.com/advancedtelematic/sota_client_cpp \
17 "
18
19DEPENDS = "boost curl openssl"
20RDEPENDS = ""
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 ${WORKDIR}/build/target/sota_client ${D}${bindir}/sota_client_cpp
25}
26
27FILES_${PN} = " \
28 ${bindir}/sota_client_cpp \
29 "