diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2019-10-14 12:06:23 +0200 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2019-10-21 12:17:01 +0200 |
commit | 29a1bd84bac8c273f5cec40560165df15f11638a (patch) | |
tree | 378fcda4b30cf11715d3f238824be922c331481b /recipes-sota | |
parent | 2b86c20024699aa4a0d464f25e9664bb169dded1 (diff) | |
download | meta-updater-29a1bd84bac8c273f5cec40560165df15f11638a.tar.gz |
aktualizr: use SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS for config recipes.
This is a bit of a compromise. These recipes are allarch, since they do
not depend on an architecture, but they depend on aktualizr, which is
definitely not allarch. Therefore, we must tell bitbake not to treat the
aktualizr architecture as a dependency of these recipes.
However, this means that if one of the config files changes in the
aktualizr repo, we need to bump the version of the recipe that uses it
to make sure bitbake picks up that change.
Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-sota')
6 files changed, 28 insertions, 1 deletions
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb b/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb index d8b29b4..a3c7d66 100644 --- a/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb +++ b/recipes-sota/aktualizr/aktualizr-device-prov-creds.bb | |||
@@ -15,6 +15,11 @@ inherit allarch | |||
15 | DEPENDS = "aktualizr aktualizr-native openssl-native" | 15 | DEPENDS = "aktualizr aktualizr-native openssl-native" |
16 | ALLOW_EMPTY_${PN} = "1" | 16 | ALLOW_EMPTY_${PN} = "1" |
17 | 17 | ||
18 | # If the config file from aktualizr used here is changed, you will need to bump | ||
19 | # the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS! | ||
20 | PV = "1.0" | ||
21 | PR = "1" | ||
22 | |||
18 | SRC_URI = " \ | 23 | SRC_URI = " \ |
19 | file://ca.cnf \ | 24 | file://ca.cnf \ |
20 | " | 25 | " |
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb index e8ef513..8d4bc9c 100644 --- a/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb +++ b/recipes-sota/aktualizr/aktualizr-device-prov-hsm.bb | |||
@@ -12,10 +12,13 @@ inherit allarch | |||
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds softhsm-testtoken' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" | 13 | RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds softhsm-testtoken' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" |
14 | 14 | ||
15 | SRC_URI = "" | 15 | # If the config file from aktualizr used here is changed, you will need to bump |
16 | # the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS! | ||
16 | PV = "1.0" | 17 | PV = "1.0" |
17 | PR = "6" | 18 | PR = "6" |
18 | 19 | ||
20 | SRC_URI = "" | ||
21 | |||
19 | do_install() { | 22 | do_install() { |
20 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 23 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
21 | install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred-hsm.toml \ | 24 | install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred-hsm.toml \ |
diff --git a/recipes-sota/aktualizr/aktualizr-device-prov.bb b/recipes-sota/aktualizr/aktualizr-device-prov.bb index fbe29a1..e8c75bb 100644 --- a/recipes-sota/aktualizr/aktualizr-device-prov.bb +++ b/recipes-sota/aktualizr/aktualizr-device-prov.bb | |||
@@ -12,9 +12,13 @@ inherit allarch | |||
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" | 13 | RDEPENDS_${PN}_append = "${@' aktualizr-device-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" |
14 | 14 | ||
15 | # If the config file from aktualizr used here is changed, you will need to bump | ||
16 | # the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS! | ||
15 | PV = "1.0" | 17 | PV = "1.0" |
16 | PR = "1" | 18 | PR = "1" |
17 | 19 | ||
20 | SRC_URI = "" | ||
21 | |||
18 | do_install() { | 22 | do_install() { |
19 | install -m 0700 -d ${D}${libdir}/sota/conf.d | 23 | install -m 0700 -d ${D}${libdir}/sota/conf.d |
20 | install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred.toml \ | 24 | install -m 0644 ${STAGING_DIR_HOST}${libdir}/sota/sota-device-cred.toml \ |
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb b/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb index b3b539d..9c6f0dd 100644 --- a/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb +++ b/recipes-sota/aktualizr/aktualizr-shared-prov-creds.bb | |||
@@ -9,6 +9,13 @@ inherit allarch | |||
9 | DEPENDS = "zip-native" | 9 | DEPENDS = "zip-native" |
10 | ALLOW_EMPTY_${PN} = "1" | 10 | ALLOW_EMPTY_${PN} = "1" |
11 | 11 | ||
12 | # If the config file from aktualizr used here is changed, you will need to bump | ||
13 | # the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS! | ||
14 | PV = "1.0" | ||
15 | PR = "1" | ||
16 | |||
17 | SRC_URI = "" | ||
18 | |||
12 | require credentials.inc | 19 | require credentials.inc |
13 | 20 | ||
14 | do_install() { | 21 | do_install() { |
diff --git a/recipes-sota/aktualizr/aktualizr-shared-prov.bb b/recipes-sota/aktualizr/aktualizr-shared-prov.bb index 00588dc..2ee47a1 100644 --- a/recipes-sota/aktualizr/aktualizr-shared-prov.bb +++ b/recipes-sota/aktualizr/aktualizr-shared-prov.bb | |||
@@ -11,6 +11,9 @@ inherit allarch | |||
11 | # the aktualizr (target) recipe. | 11 | # the aktualizr (target) recipe. |
12 | DEPENDS = "aktualizr" | 12 | DEPENDS = "aktualizr" |
13 | RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" | 13 | RDEPENDS_${PN}_append = "${@' aktualizr-shared-prov-creds' if d.getVar('SOTA_DEPLOY_CREDENTIALS') == '1' else ''}" |
14 | |||
15 | # If the config file from aktualizr used here is changed, you will need to bump | ||
16 | # the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS! | ||
14 | PV = "1.0" | 17 | PV = "1.0" |
15 | PR = "6" | 18 | PR = "6" |
16 | 19 | ||
diff --git a/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb b/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb index 5a49d16..2895e5c 100644 --- a/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb +++ b/recipes-sota/aktualizr/aktualizr-uboot-env-rollback.bb | |||
@@ -8,6 +8,11 @@ inherit allarch | |||
8 | 8 | ||
9 | DEPENDS = "aktualizr" | 9 | DEPENDS = "aktualizr" |
10 | 10 | ||
11 | # If the config file from aktualizr used here is changed, you will need to bump | ||
12 | # the version here because of SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS! | ||
13 | PV = "1.0" | ||
14 | PR = "1" | ||
15 | |||
11 | SRC_URI = "" | 16 | SRC_URI = "" |
12 | 17 | ||
13 | do_install() { | 18 | do_install() { |