summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
authorEugene Smirnov <evgenii.smirnov@here.com>2019-10-23 17:34:19 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2019-11-20 10:42:55 +0100
commitd74b923847554cce139e201554fd4962434f779a (patch)
tree16b6de32ac57bcad370de3e832564ee9d2388331 /recipes-sota
parent6ab153019a72425ec85b3f4a20f95caded27f3d1 (diff)
downloadmeta-updater-d74b923847554cce139e201554fd4962434f779a.tar.gz
Indicate an OSTree boot on start
Signed-off-by: Mykhaylo Sul <ext-mykhaylo.sul@here.com> Signed-off-by: Patrick Vacek <patrickvacek@gmail.com>
Diffstat (limited to 'recipes-sota')
-rwxr-xr-xrecipes-sota/ostree/files/touch-ostree21
-rw-r--r--recipes-sota/ostree/ostree-booted_1.0.bb15
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-sota/ostree/files/touch-ostree b/recipes-sota/ostree/files/touch-ostree
new file mode 100755
index 0000000..28cb672
--- /dev/null
+++ b/recipes-sota/ostree/files/touch-ostree
@@ -0,0 +1,21 @@
1#!/bin/sh
2### BEGIN INIT INFO
3# Provides: touch-ostree
4# Required-Start: $network $remote_fs
5# Required-Stop: $network $remote_fs
6# Default-Start: 2 3 4 5
7# Default-Stop: 0 1 6
8# Short-Description: Indicate OSTree boot
9### END INIT INFO
10
11case "$1" in
12 start)
13 touch /run/ostree-booted
14 ;;
15 stop)
16 ;;
17 *)
18 echo "Usage: /etc/init.d/touch-ostree {start|stop}"
19 exit 1
20 ;;
21esac
diff --git a/recipes-sota/ostree/ostree-booted_1.0.bb b/recipes-sota/ostree/ostree-booted_1.0.bb
new file mode 100644
index 0000000..d74cf24
--- /dev/null
+++ b/recipes-sota/ostree/ostree-booted_1.0.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Indicate an OSTree boot"
2DESCRIPTION = "Indicate an OSTree boot"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
5SRC_URI = "file://touch-ostree"
6
7inherit allarch update-rc.d
8
9INITSCRIPT_NAME = "touch-ostree"
10INITSCRIPT_PARAMS = "start 8 2 3 4 5 . stop 20 0 1 6 ."
11
12do_install() {
13 install -d ${D}${sysconfdir}/init.d
14 install -m 0755 ${WORKDIR}/touch-ostree ${D}${sysconfdir}/init.d/touch-ostree
15}