summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
authorcajun-rat <p@beta16.co.uk>2016-12-09 08:58:08 +0100
committerGitHub <noreply@github.com>2016-12-09 08:58:08 +0100
commit99b9b2c32c5756a6522bf0fafb2515695d6e8389 (patch)
treea795a417f59f22d355fcb1970f8db84b442f2bd8 /recipes-sota
parentcc928733a487f7ba7a6ca596434386fd6da3f1ab (diff)
parent00ec1ca642865bc6051d5f62df2e1bed7ba6fd58 (diff)
downloadmeta-updater-99b9b2c32c5756a6522bf0fafb2515695d6e8389.tar.gz
Merge pull request #9 from advancedtelematic/feat/credentials
Add a recipe deploying credentials on the device
Diffstat (limited to 'recipes-sota')
-rw-r--r--recipes-sota/sota-credentials/sota-credentials.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-sota/sota-credentials/sota-credentials.bb b/recipes-sota/sota-credentials/sota-credentials.bb
new file mode 100644
index 0000000..f523f21
--- /dev/null
+++ b/recipes-sota/sota-credentials/sota-credentials.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Deploy SOTA credentials on the defice"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5FILES_${PN} += "${sysconfdir}/sota.toml"
6
7ALLOW_EMPTY_${PN} = "1"
8
9export SOTA_CREDENTIALS
10
11do_install() {
12 if [ -n "$SOTA_CREDENTIALS" ]; then
13 if [ -f "$SOTA_CREDENTIALS" ]; then
14 EXT=`basename $SOTA_CREDENTIALS | cut -d'.' -f2`
15 if [ "$EXT" != "toml" ]; then
16 bbwarn "File\'s extension is not \'toml\', make sure you have the correct file"
17 fi
18
19 install -d ${D}${sysconfdir}
20 cat $SOTA_CREDENTIALS | sed 's/^package_manager = .*$/package_manager = "ostree"/' > ${D}${sysconfdir}/sota.toml
21 chmod 644 ${D}${sysconfdir}/sota.toml
22 else
23 bberror "File $SOTA_CREDENTIALS does not exist"
24 fi
25 fi
26}
27