diff options
author | Jon Oster <jon@advancedtelematic.com> | 2017-02-08 18:28:04 +0100 |
---|---|---|
committer | Phil Wise <phil@advancedtelematic.com> | 2017-02-16 17:30:21 +0100 |
commit | 5dc260e0d7818a0aca05b29e6c4cb2ae5a3b8c64 (patch) | |
tree | e1985cf1d872a36a571e6755188d6963ad7b47e3 /recipes-sota | |
parent | fbd4aac807760336c7dd26c2f271d17a8050924c (diff) | |
download | meta-updater-5dc260e0d7818a0aca05b29e6c4cb2ae5a3b8c64.tar.gz |
Change name of cpp client to 'aktualizr'
Diffstat (limited to 'recipes-sota')
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 24 | ||||
-rw-r--r-- | recipes-sota/sota-client-cpp/sota-client-cpp_git.bb | 31 |
2 files changed, 24 insertions, 31 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb new file mode 100644 index 0000000..045c142 --- /dev/null +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Aktualizr SOTA Client" | ||
2 | DESCRIPTION = "SOTA Client application written in C++" | ||
3 | HOMEPAGE = "https://github.com/advancedtelematic/aktualizr" | ||
4 | SECTION = "base" | ||
5 | |||
6 | LICENSE = "MPL-2.0" | ||
7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | ||
8 | |||
9 | inherit cmake systemd | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | SRCREV = "f2275e9938f5c942c9e51a3966b1ad91acd65367" | ||
14 | |||
15 | SRC_URI = "git://github.com/advancedtelematic/aktualizr" | ||
16 | |||
17 | DEPENDS = "boost curl openssl jansson" | ||
18 | RDEPENDS = "" | ||
19 | |||
20 | EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=OFF" | ||
21 | |||
22 | FILES_${PN} = " \ | ||
23 | ${bindir}/aktualizr \ | ||
24 | " | ||
diff --git a/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb b/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb deleted file mode 100644 index e3c5245..0000000 --- a/recipes-sota/sota-client-cpp/sota-client-cpp_git.bb +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | SUMMARY = "SOTA Client" | ||
2 | DESCRIPTION = "SOTA Client application written in C++" | ||
3 | HOMEPAGE = "https://github.com/advancedtelematic/sota_client_cpp" | ||
4 | SECTION = "base" | ||
5 | |||
6 | LICENSE = "MPL-2.0" | ||
7 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=9741c346eef56131163e13b9db1241b3" | ||
8 | |||
9 | inherit cmake systemd | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | SRCREV = "b14c668bdf914c71e68706168aa821bcae32c8f3" | ||
14 | |||
15 | SRC_URI = " \ | ||
16 | git://github.com/advancedtelematic/sota_client_cpp \ | ||
17 | " | ||
18 | |||
19 | DEPENDS = "boost curl openssl" | ||
20 | RDEPENDS = "" | ||
21 | |||
22 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release" | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}${bindir} | ||
26 | install -m 0755 ${WORKDIR}/build/target/sota_client ${D}${bindir}/sota_client_cpp | ||
27 | } | ||
28 | |||
29 | FILES_${PN} = " \ | ||
30 | ${bindir}/sota_client_cpp \ | ||
31 | " | ||