diff options
author | Phil Wise <phil@advancedtelematic.com> | 2017-06-22 12:16:03 +0200 |
---|---|---|
committer | Phil Wise <phil@advancedtelematic.com> | 2017-06-22 12:19:56 +0200 |
commit | 3eda07d8632fe6723418b47dfb3a0bb4b41129b3 (patch) | |
tree | 891f48bd89fa449b41378f5b0ecdb0b33358ef15 /recipes-sota | |
parent | 64e2fb483f6d4df8929af9ada31a72e218121f0e (diff) | |
download | meta-updater-3eda07d8632fe6723418b47dfb3a0bb4b41129b3.tar.gz |
Retry mounting sysroot
Fixes DEM-169
Diffstat (limited to 'recipes-sota')
-rw-r--r-- | recipes-sota/ostree-initrd/files/init.sh | 8 | ||||
-rw-r--r-- | recipes-sota/ostree-initrd/ostree-initrd.bb | 2 |
2 files changed, 8 insertions, 2 deletions
diff --git a/recipes-sota/ostree-initrd/files/init.sh b/recipes-sota/ostree-initrd/files/init.sh index b88716c..0b0693d 100644 --- a/recipes-sota/ostree-initrd/files/init.sh +++ b/recipes-sota/ostree-initrd/files/init.sh | |||
@@ -56,7 +56,13 @@ grep -q smackfs /proc/filesystems && { | |||
56 | mkdir -p /sysroot | 56 | mkdir -p /sysroot |
57 | ostree_sysroot=$(get_ostree_sysroot) | 57 | ostree_sysroot=$(get_ostree_sysroot) |
58 | 58 | ||
59 | mount $ostree_sysroot /sysroot || bail_out "Unable to mount $ostree_sysroot as physical sysroot" | 59 | mount "$ostree_sysroot" /sysroot || { |
60 | # The SD card in the R-Car M3 takes a bit of time to come up | ||
61 | # Retry the mount if it fails the first time | ||
62 | log_info "Mounting $ostree_sysroot failed, waiting 5s for the device to be available..." | ||
63 | sleep 5 | ||
64 | mount "$ostree_sysroot" /sysroot || bail_out "Unable to mount $ostree_sysroot as physical sysroot" | ||
65 | } | ||
60 | ostree-prepare-root /sysroot | 66 | ostree-prepare-root /sysroot |
61 | 67 | ||
62 | # move mounted devices to new root | 68 | # move mounted devices to new root |
diff --git a/recipes-sota/ostree-initrd/ostree-initrd.bb b/recipes-sota/ostree-initrd/ostree-initrd.bb index b721405..6046c81 100644 --- a/recipes-sota/ostree-initrd/ostree-initrd.bb +++ b/recipes-sota/ostree-initrd/ostree-initrd.bb | |||
@@ -5,7 +5,7 @@ SRC_URI = "file://init.sh" | |||
5 | 5 | ||
6 | S = "${WORKDIR}" | 6 | S = "${WORKDIR}" |
7 | 7 | ||
8 | PV = "2" | 8 | PV = "3" |
9 | 9 | ||
10 | do_install() { | 10 | do_install() { |
11 | install -dm 0755 ${D}/etc | 11 | install -dm 0755 ${D}/etc |