summaryrefslogtreecommitdiffstats
path: root/recipes-sota
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:00:02 +0300
committerLeon Anavi <leon.anavi@konsulko.com>2016-09-02 19:20:28 +0300
commit25deddaaa6647a59a752afe5e3d163d30e868abe (patch)
tree70d1296c7d5a06340d35d55617fbc637890c3ae4 /recipes-sota
parent19b2c68c5790dcedd6bc85e6923559e0692dad58 (diff)
downloadmeta-updater-25deddaaa6647a59a752afe5e3d163d30e868abe.tar.gz
libgsystem_git.bb: Bug fixes
Fixes for LibGSystem recipe: * Export staging directories, host and build system, * Deploy installed files in /usr/lib and /usr/share. Bug-AGL: SPEC-194 Change-Id: I9e564088d545525c791426f6a80a870f5b6b45b5 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'recipes-sota')
-rw-r--r--recipes-sota/libgsystem/libgsystem_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-sota/libgsystem/libgsystem_git.bb b/recipes-sota/libgsystem/libgsystem_git.bb
index f35819d..fe1e552 100644
--- a/recipes-sota/libgsystem/libgsystem_git.bb
+++ b/recipes-sota/libgsystem/libgsystem_git.bb
@@ -15,7 +15,23 @@ inherit autotools-brokensep
15 15
16BBCLASSEXTEND += "native" 16BBCLASSEXTEND += "native"
17 17
18export STAGING_INCDIR
19export STAGING_LIBDIR
20
18do_configure() { 21do_configure() {
19 NOCONFIGURE=true ./autogen.sh 22 NOCONFIGURE=true ./autogen.sh
20 oe_runconf 23 oe_runconf
21} 24}
25
26do_compile_prepend() {
27 export BUILD_SYS="${BUILD_SYS}"
28 export HOST_SYS="${HOST_SYS}"
29}
30
31FILES_${PN} += " \
32 ${datadir} \
33 ${datadir}/gir-1.0 \
34 ${datadir}/gir-1.0/GSystem-1.0.gir \
35 ${libdir}/girepository-1.0/ \
36 ${libdir}/girepository-1.0/GSystem-1.0.typelib \
37"