diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2019-11-07 11:50:41 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2019-11-07 11:50:41 +0100 |
commit | b98cd8c8a088588b05e1ea38eef81b14606ece37 (patch) | |
tree | 3513818cc5788d52b16b9868ae35eb286da26482 /recipes-sota | |
parent | dc19f1fb7b458c3b12843ba7a7e4aa8984bd4d7c (diff) | |
parent | 9bca3262df0c162d210ae036bb20899da3685f5d (diff) | |
download | meta-updater-b98cd8c8a088588b05e1ea38eef81b14606ece37.tar.gz |
Merge pull request #621 from ricardosalveti/ostree
Drop ostree_git in favor of the ostree recipe from meta-oe.
Diffstat (limited to 'recipes-sota')
-rw-r--r-- | recipes-sota/ostree/ostree_git.bb | 69 |
1 files changed, 0 insertions, 69 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb deleted file mode 100644 index 93ae6e7..0000000 --- a/recipes-sota/ostree/ostree_git.bb +++ /dev/null | |||
@@ -1,69 +0,0 @@ | |||
1 | SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees" | ||
2 | HOMEPAGE = "https://ostree.readthedocs.io/en/latest/" | ||
3 | LICENSE = "LGPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" | ||
5 | |||
6 | inherit autotools pkgconfig systemd bash-completion gobject-introspection | ||
7 | |||
8 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" | ||
9 | |||
10 | SRCREV = "f3eba6bcec39c163eb831c02c148ffa483292906" | ||
11 | |||
12 | PV = "v2018.9" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | BBCLASSEXTEND = "native" | ||
17 | |||
18 | DEPENDS += "attr bison-native libarchive libcap glib-2.0 gpgme fuse e2fsprogs curl xz" | ||
19 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | ||
20 | RDEPENDS_${PN}-dracut = "bash" | ||
21 | |||
22 | CFLAGS_append = " -Wno-error=missing-prototypes" | ||
23 | EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup" | ||
24 | EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" | ||
25 | |||
26 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | ||
27 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut" | ||
28 | |||
29 | # Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the | ||
30 | # do_configure stage so we do depend on it | ||
31 | SYSROOT_DIR = "${STAGING_DIR_TARGET}" | ||
32 | SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}" | ||
33 | do_configure[vardeps] += "SYSROOT_DIR" | ||
34 | |||
35 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service ostree-finalize-staged.service" | ||
36 | |||
37 | export BUILD_SYS | ||
38 | export HOST_SYS | ||
39 | export STAGING_INCDIR | ||
40 | export STAGING_LIBDIR | ||
41 | |||
42 | do_configure_prepend() { | ||
43 | unset docdir | ||
44 | NOCONFIGURE=1 "${S}/autogen.sh" | ||
45 | } | ||
46 | |||
47 | do_install_append_class-native() { | ||
48 | create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator" | ||
49 | } | ||
50 | |||
51 | PACKAGES += " \ | ||
52 | ${PN}-switchroot \ | ||
53 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'ostree-dracut', '', d)} \ | ||
54 | " | ||
55 | |||
56 | FILES_${PN} = "${bindir} \ | ||
57 | ${sysconfdir}/ostree \ | ||
58 | ${datadir}/ostree \ | ||
59 | ${libdir}/*.so.* \ | ||
60 | ${libdir}/ostree/ostree-grub-generator \ | ||
61 | ${libdir}/ostree/ostree-remount \ | ||
62 | ${libdir}/girepository-1.0/* \ | ||
63 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/tmpfiles.d', '', d)} \ | ||
64 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system/*.path', '', d)} \ | ||
65 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system-generators', '', d)} \ | ||
66 | " | ||
67 | FILES_${PN}-dev += " ${datadir}/gir-1.0" | ||
68 | FILES_${PN}-dracut = "${sysconfdir}/dracut.conf.d ${libdir}/dracut" | ||
69 | FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" | ||