diff options
author | Patrick Vacek <patrickvacek@gmail.com> | 2018-04-05 11:12:01 +0200 |
---|---|---|
committer | Patrick Vacek <patrickvacek@gmail.com> | 2018-04-13 08:44:58 +0200 |
commit | dc8096010ebcb4b5110db50456a892fde12a9f4a (patch) | |
tree | c98c130325dd4840f6316421f5b801e5b23d8528 /recipes-sota | |
parent | 192aa31f8783a669baef8751087d1db89c5b2a52 (diff) | |
download | meta-updater-dc8096010ebcb4b5110db50456a892fde12a9f4a.tar.gz |
Pass requested garage-sign version to aktualizr.
Set GARAGE_SIGN_VERSION in local.conf to request a specific version, e.g.:
GARAGE_SIGN_VERSION = "cli-0.3.0-5-g5908997.tgz"
If unset, the default (latest version) will be used.
Set GARAGE_SIGN_SHA256 in local.conf to specify a hash to check, e.g.:
GARAGE_SIGN_SHA256 = "94f5db1accbbbaa279f7ac5a2e618f5448adeafbe32d6cbc90c8604054ab653e"
If unset, the sha256 is not computed.
Diffstat (limited to 'recipes-sota')
-rw-r--r-- | recipes-sota/aktualizr/aktualizr_git.bb | 18 |
1 files changed, 13 insertions, 5 deletions
diff --git a/recipes-sota/aktualizr/aktualizr_git.bb b/recipes-sota/aktualizr/aktualizr_git.bb index 2a803a8..4305b2c 100644 --- a/recipes-sota/aktualizr/aktualizr_git.bb +++ b/recipes-sota/aktualizr/aktualizr_git.bb | |||
@@ -37,9 +37,17 @@ SYSTEMD_SERVICE_${PN}-secondary = "aktualizr-secondary.socket" | |||
37 | 37 | ||
38 | BBCLASSEXTEND =+ "native" | 38 | BBCLASSEXTEND =+ "native" |
39 | 39 | ||
40 | EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF -DCMAKE_BUILD_TYPE=Release -DAKTUALIZR_VERSION=${PV} " | 40 | EXTRA_OECMAKE = "-DWARNING_AS_ERROR=OFF \ |
41 | EXTRA_OECMAKE_append_class-target = " -DBUILD_OSTREE=ON -DBUILD_ISOTP=ON ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'hsm', '-DBUILD_P11=ON', '', d)} " | 41 | -DCMAKE_BUILD_TYPE=Release \ |
42 | EXTRA_OECMAKE_append_class-native = " -DBUILD_SOTA_TOOLS=ON -DBUILD_OSTREE=OFF -DBUILD_SYSTEMD=OFF " | 42 | -DAKTUALIZR_VERSION=${PV} " |
43 | EXTRA_OECMAKE_append_class-target = " -DBUILD_OSTREE=ON \ | ||
44 | -DBUILD_ISOTP=ON \ | ||
45 | ${@bb.utils.contains('SOTA_CLIENT_FEATURES', 'hsm', '-DBUILD_P11=ON', '', d)} " | ||
46 | EXTRA_OECMAKE_append_class-native = " -DBUILD_SOTA_TOOLS=ON \ | ||
47 | -DBUILD_OSTREE=OFF \ | ||
48 | -DBUILD_SYSTEMD=OFF \ | ||
49 | -DGARAGE_SIGN_VERSION=${GARAGE_SIGN_VERSION} \ | ||
50 | -DGARAGE_SIGN_SHA256=${GARAGE_SIGN_SHA256}" | ||
43 | 51 | ||
44 | do_install_append () { | 52 | do_install_append () { |
45 | rm -fr ${D}${libdir}/systemd | 53 | rm -fr ${D}${libdir}/systemd |
@@ -65,8 +73,8 @@ do_install_append_class-native () { | |||
65 | install -m 0644 ${S}/config/sota_implicit_prov.toml ${D}/${libdir}/sota/sota_implicit_prov.toml | 73 | install -m 0644 ${S}/config/sota_implicit_prov.toml ${D}/${libdir}/sota/sota_implicit_prov.toml |
66 | install -m 0644 ${S}/config/sota_implicit_prov_ca.toml ${D}/${libdir}/sota/sota_implicit_prov_ca.toml | 74 | install -m 0644 ${S}/config/sota_implicit_prov_ca.toml ${D}/${libdir}/sota/sota_implicit_prov_ca.toml |
67 | 75 | ||
68 | install -m 0755 ${B}/src/sota_tools/garage-sign-prefix/src/garage-sign/bin/* ${D}${bindir} | 76 | install -m 0755 ${B}/src/sota_tools/garage-sign/bin/* ${D}${bindir} |
69 | install -m 0644 ${B}/src/sota_tools/garage-sign-prefix/src/garage-sign/lib/* ${D}${libdir} | 77 | install -m 0644 ${B}/src/sota_tools/garage-sign/lib/* ${D}${libdir} |
70 | } | 78 | } |
71 | 79 | ||
72 | PACKAGES =+ " ${PN}-common ${PN}-examples ${PN}-host-tools ${PN}-secondary " | 80 | PACKAGES =+ " ${PN}-common ${PN}-examples ${PN}-host-tools ${PN}-secondary " |