summaryrefslogtreecommitdiffstats
path: root/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
diff options
context:
space:
mode:
authorPatrick Vacek <patrickvacek@gmail.com>2017-08-02 12:26:51 +0200
committerPatrick Vacek <patrickvacek@gmail.com>2017-08-07 17:01:57 +0200
commitb20eb4aa872f00827d0c079d30a61bd86f68866e (patch)
treeddbd7e5eec3bbe00752562df026167a060be8a50 /recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
parentb376ae9e08c4695b95b02fbecfe55eb1bd05c603 (diff)
downloadmeta-updater-b20eb4aa872f00827d0c079d30a61bd86f68866e.tar.gz
Prepare credentials correctly for rvi-sota-client.
Unzip credentials archive and create files as appropriate, since none of that is necessary for aktualizr anymore. This is now done in the sota_provision script. It apparently does not work in the rvi-sota-client recipe, but this solution is perhaps even cleaner anyway.
Diffstat (limited to 'recipes-sota/rvi-sota-client/rvi-sota-client_git.bb')
-rw-r--r--recipes-sota/rvi-sota-client/rvi-sota-client_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
index 7ce3ab5..e286598 100644
--- a/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
+++ b/recipes-sota/rvi-sota-client/rvi-sota-client_git.bb
@@ -24,11 +24,10 @@ lshw \
24jq \ 24jq \
25python-petname \ 25python-petname \
26sota-launcher \ 26sota-launcher \
27zip \
27" 28"
28 29
29export SOTA_PACKED_CREDENTIALS 30export SOTA_PACKED_CREDENTIALS
30export SOTA_AUTOPROVISION_CREDENTIALS
31export SOTA_AUTOPROVISION_URL
32 31
33do_compile_prepend() { 32do_compile_prepend() {
34 export SOTA_VERSION=$(make sota-version) 33 export SOTA_VERSION=$(make sota-version)
@@ -50,7 +49,7 @@ do_install() {
50 49
51 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 50 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
52 install -d ${D}/${systemd_unitdir}/system 51 install -d ${D}/${systemd_unitdir}/system
53 if [ -n "$SOTA_AUTOPROVISION_CREDENTIALS" -o -n "$SOTA_PACKED_CREDENTIALS" ]; then 52 if [ -n "$SOTA_PACKED_CREDENTIALS" ]; then
54 install -m 0644 ${WORKDIR}/sota-client-uptane.service ${D}/${systemd_unitdir}/system/sota-client.service 53 install -m 0644 ${WORKDIR}/sota-client-uptane.service ${D}/${systemd_unitdir}/system/sota-client.service
55 else 54 else
56 install -m 0644 ${WORKDIR}/sota-client-ostree.service ${D}/${systemd_unitdir}/system/sota-client.service 55 install -m 0644 ${WORKDIR}/sota-client-ostree.service ${D}/${systemd_unitdir}/system/sota-client.service