diff options
author | Ricardo Salveti <ricardo@opensourcefoundries.com> | 2018-05-04 22:51:23 -0300 |
---|---|---|
committer | Ricardo Salveti <ricardo@opensourcefoundries.com> | 2018-06-12 16:55:19 -0300 |
commit | 9f30ec0c0b818c5268964b845a380270d03d3346 (patch) | |
tree | 2e245fa4d065dc29491879478ef9e460a97d6a80 /recipes-sota/ostree | |
parent | 9b709a079d30a005f7187517466c81f9119b10fd (diff) | |
download | meta-updater-9f30ec0c0b818c5268964b845a380270d03d3346.tar.gz |
ostree: no need to disable systemd when building native
Maintaining different build flags for target and native just makes it
harder to maintain the recipe and it is not really needed as
systemd-native is already available for systems building systemd.
Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
Diffstat (limited to 'recipes-sota/ostree')
-rw-r--r-- | recipes-sota/ostree/ostree_git.bb | 7 |
1 files changed, 0 insertions, 7 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb index b948131..39d3c48 100644 --- a/recipes-sota/ostree/ostree_git.bb +++ b/recipes-sota/ostree/ostree_git.bb | |||
@@ -5,8 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" | |||
5 | 5 | ||
6 | inherit autotools pkgconfig systemd gobject-introspection | 6 | inherit autotools pkgconfig systemd gobject-introspection |
7 | 7 | ||
8 | INHERIT_remove_class-native = "systemd" | ||
9 | |||
10 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" | 8 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" |
11 | 9 | ||
12 | SRCREV="854a823e05d6fe8b610c02c2a71eaeb2bf1e98a6" | 10 | SRCREV="854a823e05d6fe8b610c02c2a71eaeb2bf1e98a6" |
@@ -20,7 +18,6 @@ BBCLASSEXTEND = "native" | |||
20 | 18 | ||
21 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse e2fsprogs gtk-doc-native curl xz" | 19 | DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse e2fsprogs gtk-doc-native curl xz" |
22 | DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" | 20 | DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
23 | DEPENDS_remove_class-native = "systemd-native" | ||
24 | 21 | ||
25 | RDEPENDS_${PN} = "util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash" | 22 | RDEPENDS_${PN} = "util-linux-libuuid util-linux-libblkid util-linux-libmount libcap bash" |
26 | 23 | ||
@@ -35,13 +32,10 @@ SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}" | |||
35 | do_configure[vardeps] += "SYSROOT_DIR" | 32 | do_configure[vardeps] += "SYSROOT_DIR" |
36 | 33 | ||
37 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" | 34 | SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" |
38 | SYSTEMD_REQUIRED_class-native = "" | ||
39 | 35 | ||
40 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" | 36 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" |
41 | SYSTEMD_SERVICE_${PN}_class-native = "" | ||
42 | 37 | ||
43 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" | 38 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
44 | PACKAGECONFIG_class-native = "" | ||
45 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut" | 39 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut" |
46 | 40 | ||
47 | FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" | 41 | FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" |
@@ -86,4 +80,3 @@ PACKAGES =+ "${PN}-switchroot" | |||
86 | 80 | ||
87 | FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" | 81 | FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" |
88 | RDEPENDS_${PN}-switchroot = "" | 82 | RDEPENDS_${PN}-switchroot = "" |
89 | DEPENDS_remove_class-native = "systemd-native" | ||