summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-07-15 18:01:44 +0300
committerLeon Anavi <leon.anavi@konsulko.com>2016-07-15 18:01:44 +0300
commit62cf4059c09962243346c496ee867e9ca79387b4 (patch)
treea4e82be8a7d81f93a67b5912458b5b5d3d3e3204 /recipes-sota/ostree
parent459f24cba4ba12f27f7f30500f29988389857011 (diff)
downloadmeta-updater-62cf4059c09962243346c496ee867e9ca79387b4.tar.gz
ostree: systemd services
Ensure that systemd services ostree-prepare-root and ostree-remount are installed and deployed. Change-Id: I5774ade1278cb1429c583a21066c51432d0c1a2a Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'recipes-sota/ostree')
-rw-r--r--recipes-sota/ostree/ostree_git.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index 57f03d4..760dd32 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -2,6 +2,8 @@ SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" 3LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
4 4
5inherit autotools-brokensep pkgconfig systemd
6
5SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 7SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
6SRCREV="v2016.7" 8SRCREV="v2016.7"
7 9
@@ -11,7 +13,8 @@ DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4
11 13
12RDEPENDS_${PN} = "python libsystemd util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma" 14RDEPENDS_${PN} = "python libsystemd util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma"
13 15
14inherit autotools-brokensep 16PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
17PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,"
15 18
16EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man" 19EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
17 20
@@ -23,3 +26,16 @@ do_configure() {
23 NOCONFIGURE=true ./autogen.sh 26 NOCONFIGURE=true ./autogen.sh
24 oe_runconf 27 oe_runconf
25} 28}
29
30do_install_append() {
31 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
32 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
33 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
34 fi
35}
36
37SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
38FILES_${PN} += " \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_unitdir}/system/', '', d)} \
40 ${libdir}/dracut/ \
41"