summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-12-09 17:31:23 +0100
committerAnton Gerasimov <anton@advancedtelematic.com>2016-12-20 14:02:34 +0100
commiteff667c136570fa52ed51e2c8d3c38502272b4fb (patch)
tree7d28a575bd7f3ccbd9a3f605f8f904549bcbe074 /recipes-sota/ostree
parente562aef8830c6d6e12656d9414c35b30bf78b050 (diff)
downloadmeta-updater-eff667c136570fa52ed51e2c8d3c38502272b4fb.tar.gz
Make systemd optional
Diffstat (limited to 'recipes-sota/ostree')
-rw-r--r--recipes-sota/ostree/ostree_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index d444669..b6adf9b 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -14,7 +14,9 @@ S = "${WORKDIR}/git"
14 14
15BBCLASSEXTEND = "native" 15BBCLASSEXTEND = "native"
16 16
17DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs systemd" 17DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4 e2fsprogs"
18DEPENDS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
19
18DEPENDS_remove_class-native = "systemd-native" 20DEPENDS_remove_class-native = "systemd-native"
19 21
20RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz os-release" 22RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz os-release"
@@ -25,7 +27,7 @@ EXTRA_OEMAKE = "CFLAGS='-g'"
25EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat" 27EXTRA_OECONF_append_class-native = " --enable-wrpseudo-compat"
26 28
27SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" 29SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
28SYSTEMD_REQUIRED_class-native = "" 30SYSTEMD_REQUIRED_class-native = "false"
29 31
30SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" 32SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service"
31SYSTEMD_SERVICE_${PN}_class-native = "" 33SYSTEMD_SERVICE_${PN}_class-native = ""
@@ -52,8 +54,7 @@ do_compile_prepend() {
52export SYSTEMD_REQUIRED 54export SYSTEMD_REQUIRED
53 55
54do_install_append() { 56do_install_append() {
55 if [ -n ${SYSTEMD_REQUIRED} ]; then 57 if [ "$SYSTEMD_REQUIRED" == "true" ]; then
56 install -p -D ${S}/src/boot/ostree-prepare-root.service ${D}${systemd_unitdir}/system/ostree-prepare-root.service
57 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service 58 install -p -D ${S}/src/boot/ostree-remount.service ${D}${systemd_unitdir}/system/ostree-remount.service
58 fi 59 fi
59} 60}