diff options
author | Ricardo Salveti <ricardo@opensourcefoundries.com> | 2018-05-04 23:04:42 -0300 |
---|---|---|
committer | Ricardo Salveti <ricardo@opensourcefoundries.com> | 2018-06-12 17:07:29 -0300 |
commit | b7da9e5e9ef87c9679d0f81098657d1e4e6a0c01 (patch) | |
tree | 66ffa9fd34afc624dfbcb595b9cfa131158c2c0f /recipes-sota/ostree | |
parent | ca9c09e6550c31ec757d8d105195bc73810abc90 (diff) | |
download | meta-updater-b7da9e5e9ef87c9679d0f81098657d1e4e6a0c01.tar.gz |
ostree: improve package split logic and define extra packages
Define extra packages to cover the bash-completion and dracut related
files, as they are not necessarily required by ostree.
Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
Diffstat (limited to 'recipes-sota/ostree')
-rw-r--r-- | recipes-sota/ostree/ostree_git.bb | 34 |
1 files changed, 17 insertions, 17 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb index dc31efe..6fa6ad4 100644 --- a/recipes-sota/ostree/ostree_git.bb +++ b/recipes-sota/ostree/ostree_git.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "https://ostree.readthedocs.io/en/latest/" | |||
3 | LICENSE = "LGPLv2+" | 3 | LICENSE = "LGPLv2+" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
5 | 5 | ||
6 | inherit autotools pkgconfig systemd gobject-introspection | 6 | inherit autotools pkgconfig systemd bash-completion gobject-introspection |
7 | 7 | ||
8 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" | 8 | SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" |
9 | 9 | ||
@@ -18,7 +18,7 @@ BBCLASSEXTEND = "native" | |||
18 | 18 | ||
19 | DEPENDS += "attr libarchive libcap glib-2.0 gpgme libgsystem fuse e2fsprogs curl xz" | 19 | DEPENDS += "attr libarchive libcap glib-2.0 gpgme libgsystem fuse e2fsprogs curl xz" |
20 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | 20 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
21 | RDEPENDS_${PN} = "bash" | 21 | RDEPENDS_${PN}-dracut = "bash" |
22 | 22 | ||
23 | CFLAGS_append = " -Wno-error=missing-prototypes" | 23 | CFLAGS_append = " -Wno-error=missing-prototypes" |
24 | EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup" | 24 | EXTRA_OECONF = "--disable-gtk-doc --disable-man --with-smack --with-builtin-grub2-mkconfig --with-curl --without-soup" |
@@ -35,8 +35,6 @@ do_configure[vardeps] += "SYSROOT_DIR" | |||
35 | 35 | ||
36 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" | 36 | SYSTEMD_SERVICE_${PN} = "ostree-prepare-root.service ostree-remount.service" |
37 | 37 | ||
38 | FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" | ||
39 | |||
40 | export BUILD_SYS | 38 | export BUILD_SYS |
41 | export HOST_SYS | 39 | export HOST_SYS |
42 | export STAGING_INCDIR | 40 | export STAGING_INCDIR |
@@ -51,19 +49,21 @@ do_install_append_class-native() { | |||
51 | create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator" | 49 | create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator" |
52 | } | 50 | } |
53 | 51 | ||
54 | 52 | PACKAGES += " \ | |
55 | FILES_${PN} += " \ | 53 | ${PN}-switchroot \ |
56 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/dracut', '', d)} \ | 54 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'ostree-dracut', '', d)} \ |
57 | ${datadir}/gir-1.0 \ | ||
58 | ${datadir}/gir-1.0/OSTree-1.0.gir \ | ||
59 | ${libdir}/girepository-1.0 \ | ||
60 | ${libdir}/girepository-1.0/OSTree-1.0.typelib \ | ||
61 | ${libdir}/tmpfiles.d/ostree-tmpfiles.conf \ | ||
62 | ${datadir}/bash-completion/completions/ostree \ | ||
63 | ${systemd_unitdir}/system-generators/ostree-system-generator \ | ||
64 | " | 55 | " |
65 | 56 | ||
66 | PACKAGES =+ "${PN}-switchroot" | 57 | FILES_${PN} = "${bindir} \ |
67 | 58 | ${sysconfdir}/ostree \ | |
59 | ${datadir}/ostree \ | ||
60 | ${libdir}/*.so.* \ | ||
61 | ${libdir}/ostree/ostree-grub-generator \ | ||
62 | ${libdir}/ostree/ostree-remount \ | ||
63 | ${libdir}/girepository-1.0/* \ | ||
64 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','${libdir}/tmpfiles.d', '', d)} \ | ||
65 | ${@bb.utils.contains('DISTRO_FEATURES','systemd','${systemd_unitdir}/system-generators', '', d)} \ | ||
66 | " | ||
67 | FILES_${PN}-dev += " ${datadir}/gir-1.0" | ||
68 | FILES_${PN}-dracut = "${sysconfdir}/dracut.conf.d ${libdir}/dracut" | ||
68 | FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" | 69 | FILES_${PN}-switchroot = "${libdir}/ostree/ostree-prepare-root" |
69 | RDEPENDS_${PN}-switchroot = "" | ||