summaryrefslogtreecommitdiffstats
path: root/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-09-26 15:44:53 +0200
committerAnton Gerasimov <anton@advancedtelematic.com>2016-09-26 15:44:53 +0200
commit844ddcf4496edfdb9b682f712ab1ae1cd16f1f97 (patch)
tree5cb9794fb8630c32797b9687cd847d7b954b55cd /recipes-sota/ostree/ostree_git.bb
parent0983092cf61779b70cb41741bd4913b0f0f0fbac (diff)
downloadmeta-updater-844ddcf4496edfdb9b682f712ab1ae1cd16f1f97.tar.gz
Added initramfs image and fixed several error to make AGL rootfs
bootable as an OSTree deployment Bug-AGL: SPEC-253 Change-Id: If636a282d51a64c73c46ce70a361518c1f70cdd6 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'recipes-sota/ostree/ostree_git.bb')
-rw-r--r--recipes-sota/ostree/ostree_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-sota/ostree/ostree_git.bb b/recipes-sota/ostree/ostree_git.bb
index a35799e..6adac5f 100644
--- a/recipes-sota/ostree/ostree_git.bb
+++ b/recipes-sota/ostree/ostree_git.bb
@@ -7,7 +7,7 @@ inherit autotools-brokensep pkgconfig systemd
7INHERIT_remove_class-native = "systemd" 7INHERIT_remove_class-native = "systemd"
8 8
9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master" 9SRC_URI = "gitsm://github.com/ostreedev/ostree.git;branch=master"
10SRCREV="v2016.10" 10SRCREV="v2016.5"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
@@ -19,7 +19,8 @@ DEPENDS_remove_class-native = "systemd-native"
19RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz" 19RDEPENDS_${PN} = "python util-linux-libuuid util-linux-libblkid util-linux-libmount libcap xz"
20RDEPENDS_${PN}_remove_class-native = "python-native" 20RDEPENDS_${PN}_remove_class-native = "python-native"
21 21
22EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man" 22EXTRA_OECONF = "CFLAGS='-DDISABLE_OTMPFILE' --with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
23EXTRA_OEMAKE = "CFLAGS='-DDISABLE_OTMPFILE'"
23 24
24SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}" 25SYSTEMD_REQUIRED = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
25SYSTEMD_REQUIRED_class-native = "" 26SYSTEMD_REQUIRED_class-native = ""
@@ -29,7 +30,7 @@ SYSTEMD_SERVICE_${PN}_class-native = ""
29 30
30PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 31PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
31PACKAGECONFIG_class-native = "" 32PACKAGECONFIG_class-native = ""
32PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,," 33PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/ --with-dracut"
33 34
34FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild" 35FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
35 36
@@ -57,6 +58,7 @@ do_install_append() {
57 58
58FILES_${PN} += " \ 59FILES_${PN} += " \
59 ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \ 60 ${@'${systemd_unitdir}/system/' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
61 ${@'${libdir}/dracut/modules.d/98ostree/module-setup.sh' if d.getVar('SYSTEMD_REQUIRED', True) else ''} \
60 ${datadir}/gir-1.0 \ 62 ${datadir}/gir-1.0 \
61 ${datadir}/gir-1.0/OSTree-1.0.gir \ 63 ${datadir}/gir-1.0/OSTree-1.0.gir \
62 ${libdir}/girepository-1.0 \ 64 ${libdir}/girepository-1.0 \